[packages] multimedia/uvc-streamer: Actually use the start-stop-daemon. Seems the...
[openwrt/svn-archive/archive.git] / multimedia / palantir / Makefile
index ccf3b0e34f38819e5091bc2815d78dfc8e235845..58f6a1c86c368fb1eacf03c23cce296257490be5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,29 +9,29 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=palantir
-PKG_VERSION:=2.6
+PKG_VERSION:=2.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.fastpath.it/products/palantir/pub/
-PKG_MD5SUM:=8e4d20e7f7fad26d7447483c68894ace
-PKG_CAT:=zcat
+PKG_MD5SUM:=3a5b1fb340857f6d8e357bf39b77583e
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-PKG_BUILDDEP:=libjpeg
+PKG_BUILD_DEPENDS:=libjpeg
 
 define Package/palantir
   SECTION:=multimedia
   CATEGORY:=Multimedia
+  DEPENDS:=+libjpeg +libpthread
   TITLE:=A multichannel interactive streaming solution
-  DESCRIPTION:=\
-       Palantir is a Linux-based streaming system designed to transmit live \\\
-       video, audio and data over a TCP/IP network, as well as to control \\\
-       remote devices.
   URL:=http://www.fastpath.it/products/palantir/
 endef
 
+define Package/palantir/description
+       Palantir is a Linux-based streaming system designed to transmit live
+       video, audio and data over a TCP/IP network, as well as to control
+       remote devices.
+endef
+
 define Package/palantir/conffiles
 /etc/palantir.conf
 endef
@@ -42,8 +42,6 @@ export CPPFLAGS=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
 export LDFLAGS=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
 
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)/usr
        $(MAKE) -C $(PKG_BUILD_DIR)/server/libgsm \
                $(TARGET_CONFIGURE_OPTS) \
                CCINC="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
@@ -56,10 +54,10 @@ define Build/Compile
 endef
 
 define Package/palantir/install        
-       install -d -m0755 $(1)/etc
-       install -m0644 $(PKG_BUILD_DIR)/server/palantir-mips.conf.sample $(1)/etc/palantir.conf
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/server/palantir $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/server/palantir-mips.conf.sample $(1)/etc/palantir.conf
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/server/palantir $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,palantir))