packages: Fix dbus. Closes #2562, thanks loswillios
[openwrt/svn-archive/archive.git] / multimedia / palantir / Makefile
index f8b8800f2eef6c4b0f49e3978a50d3a9adf5a000..cc12909a3dd3e90807c368207c7e00236d17d8c8 100644 (file)
@@ -15,23 +15,24 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.fastpath.it/products/palantir/pub/
 PKG_MD5SUM:=8e4d20e7f7fad26d7447483c68894ace
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
-PKG_BUILDDEP:=libjpeg
+PKG_BUILD_DEPENDS:=libjpeg
 
 define Package/palantir
   SECTION:=multimedia
   CATEGORY:=Multimedia
   TITLE:=A multichannel interactive streaming solution
-  DESCRIPTION:=\
-       Palantir is a Linux-based streaming system designed to transmit live \\\
-       video, audio and data over a TCP/IP network, as well as to control \\\
-       remote devices.
   URL:=http://www.fastpath.it/products/palantir/
 endef
 
+define Package/palantir/description
+       Palantir is a Linux-based streaming system designed to transmit live 
+       video, audio and data over a TCP/IP network, as well as to control 
+       remote devices.
+endef
+
 define Package/palantir/conffiles
 /etc/palantir.conf
 endef
@@ -54,10 +55,10 @@ define Build/Compile
 endef
 
 define Package/palantir/install        
-       install -d -m0755 $(1)/etc
-       install -m0644 $(PKG_BUILD_DIR)/server/palantir-mips.conf.sample $(1)/etc/palantir.conf
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/server/palantir $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/server/palantir-mips.conf.sample $(1)/etc/palantir.conf
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/server/palantir $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,palantir))