[package] strip down gstreamer, package more modules (#6320)
[openwrt/svn-archive/archive.git] / multimedia / palantir / Makefile
index fde73e2987c44c13928e5a99a2a4336e94b4dc47..d80ac507e302cc891f15db77543e76f878ca897c 100644 (file)
@@ -1,36 +1,33 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=palantir
-PKG_VERSION:=2.6
+PKG_VERSION:=2.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.fastpath.it/products/palantir/pub/
-PKG_MD5SUM:=8e4d20e7f7fad26d7447483c68894ace
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=3a5b1fb340857f6d8e357bf39b77583e
 
 PKG_BUILD_DEPENDS:=libjpeg
 
 define Package/palantir
   SECTION:=multimedia
   CATEGORY:=Multimedia
+  DEPENDS:=+libjpeg +libpthread
   TITLE:=A multichannel interactive streaming solution
   URL:=http://www.fastpath.it/products/palantir/
 endef
 
 define Package/palantir/description
-       Palantir is a Linux-based streaming system designed to transmit live 
-       video, audio and data over a TCP/IP network, as well as to control 
+       Palantir is a Linux-based streaming system designed to transmit live
+       video, audio and data over a TCP/IP network, as well as to control
        remote devices.
 endef
 
@@ -40,13 +37,13 @@ endef
 
 include $(INCLUDE_DIR)/package.mk
 
-export CPPFLAGS=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
-export LDFLAGS=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+export CPPFLAGS=$(TARGET_CPPFLAGS)
+export LDFLAGS=$(TARGET_LDFLAGS)
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)/server/libgsm \
                $(TARGET_CONFIGURE_OPTS) \
-               CCINC="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               CCINC="$(TARGET_CPPFLAGS)" \
                COPTS="$(TARGET_CFLAGS)" \
                lib/libgsm.a
        $(MAKE) -C $(PKG_BUILD_DIR)/server \