convert rdiff-backup to new python packaging
[openwrt/svn-archive/archive.git] / multimedia / peercast / Makefile
index 6988ae464b3b4a5d4a177063b4ad69dc21e829ea..1eb99d11144ce345e0d2e8f4f81abdb75f1ce504 100644 (file)
@@ -15,10 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.cti.ecp.fr/~beauxir5/peercast
 PKG_MD5SUM:=4e8449cde7135ad97f788e67e1bd64ee
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,11 +23,6 @@ define Package/peercast
   CATEGORY:=Multimedia
   DEPENDS:=+libpthread +uclibcxx
   TITLE:=P2P audio and video streaming server
-  DESCRIPTION:=\
-       PeerCast is a fresh new P2P streaming server. It can stream music \\\
-       and video from a broad variety of formats. Many audio players can \\\
-       listen to peercast streams, as it's been built to remain compatible \\\
-       with Nullsoft Shoutcast.
   URL:=http://www.peercast.org/
 endef
 
@@ -39,15 +30,21 @@ define Package/peercast/conffiles
 /etc/peercast.ini
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-staticbin \
-               , \
-               CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
-               LIBS="-nodefaultlibs -luClibc++ -lpthread -lc -lm" \
-       )
+define Package/peercast/description
+ PeerCast is a fresh new P2P streaming server. It can stream music and 
+ video from a broad variety of formats. Many audio players can listen to 
+ peercast streams, as it's been built to remain compatible with Nullsoft 
+ Shoutcast.
 endef
 
+CONFIGURE_ARGS += \
+       --enable-staticbin \
+
+CONFIGURE_VARS += \
+       CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
+       CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
+       LIBS="-nodefaultlibs -luClibc++ -lpthread" \
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -55,14 +52,14 @@ define Build/Compile
 endef
 
 define Package/peercast/install        
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/peercast $(1)/usr/sbin/
-       install -d -m0755 $(1)/usr/share/peercast/html
+       $(INSTALL_DIR) $(1)/usr/share/peercast/html
        $(CP) $(PKG_INSTALL_DIR)/usr/share/peercast/html/en $(1)/usr/share/peercast/html/
-       install -d -m0755 $(1)/etc
-       install -m0644 ./files/peercast.ini $(1)/etc/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/peercast.init $(1)/etc/init.d/peercast
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/peercast.ini $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/peercast.init $(1)/etc/init.d/peercast
 endef
 
 $(eval $(call BuildPackage,peercast))