[package] openssh: add ESSENTIAL_PROCESSES
[openwrt/svn-archive/archive.git] / multimedia / peercast / Makefile
index aec2c0944feee3841b70864a6a829b71d44a664a..fec240be81ea9d6bd33804c42e434fb856f6554f 100644 (file)
@@ -1,36 +1,33 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=peercast
 PKG_VERSION:=0.1214
-PKG_RELEASE:=1
-PKG_MD5SUM:=4e8449cde7135ad97f788e67e1bd64ee
+PKG_RELEASE:=3
 
-PKG_SOURCE_URL:=http://www.cti.ecp.fr/~beauxir5/peercast
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.cti.ecp.fr/~beauxir5/peercast
+PKG_MD5SUM:=4e8449cde7135ad97f788e67e1bd64ee
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES:=aclocal.m4 acinclude.m4
 
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/peercast
   SECTION:=multimedia
   CATEGORY:=Multimedia
-  DEPENDS:=+libpthread +uclibcxx
+  DEPENDS:=+libpthread $(CXX_DEPENDS)
   TITLE:=P2P audio and video streaming server
-  DESCRIPTION:=PeerCast is a fresh new P2P streaming server. It can stream music\\\
-       and video from a broad variety of formats. Many audio players can\\\
-       listen to peercast streams, as it's been built to remain compatible\\\
-       with Nullsoft Shoutcast.\\\
   URL:=http://www.peercast.org/
 endef
 
@@ -38,34 +35,30 @@ define Package/peercast/conffiles
 /etc/peercast.ini
 endef
 
-define Build/Configure
-$(call Build/Configure/Default,--enable-shared \
-                       --disable-static \
-                       --with-gnu-ld \
-                       --enable-staticbin, \
-               $(TARGET_CONFIGURE_OPTS) \
-               BUILD_CC="$(TARGET_CC)" HOSTCC="$(HOSTCC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -nostdinc++ -nodefaultlibs" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               LIBS="-nodefaultlibs -luClibc++ -lpthread")
+define Package/peercast/description
+ PeerCast is a fresh new P2P streaming server. It can stream music and 
+ video from a broad variety of formats. Many audio players can listen to 
+ peercast streams, as it's been built to remain compatible with Nullsoft 
+ Shoutcast.
 endef
 
-define Build/Compile
-  $(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" all install)
-endef
+CONFIGURE_ARGS += \
+       --enable-staticbin \
+
+CONFIGURE_VARS += \
+       LIBS="-lpthread"
+
+TARGET_CFLAGS += -fpermissive
 
-define Package/peercast/install        
-       install -m0755 -d $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/peercast $(1)/usr/sbin/
-       install -m0755 -d $(1)/usr/share/peercast/html
+define Package/peercast/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/peercast $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/share/peercast/html
        $(CP) $(PKG_INSTALL_DIR)/usr/share/peercast/html/en $(1)/usr/share/peercast/html/
-       install -m0755 -d $(1)/etc
-       install -m0644 ./files/peercast.ini $(1)/etc/
-       install -m0755 -d $(1)/etc/init.d
-       install -m0755 ./files/peercast.init $(1)/etc/init.d/peercast
-       ln -sf peercast $(1)/etc/init.d/S60peercast
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/peercast.ini $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/peercast.init $(1)/etc/init.d/peercast
 endef
 
 $(eval $(call BuildPackage,peercast))