Added package libpfm (note this package also requires perfmon2 be patched into the...
[openwrt/svn-archive/archive.git] / multimedia / ushare / Makefile
index 6c7c865a781075957d8b44983c87181f98c676b3..b37397eb40736f13798eda727e0cef418bfa13f7 100644 (file)
@@ -55,6 +55,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               INSTALL="install" \
                all install
 endef
 
@@ -67,6 +68,10 @@ define Package/ushare/install
        $(CP) $(PKG_INSTALL_DIR)/etc/ushare.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ushare $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,ushare))