[Packages] multimedia/uvc-streamer: Fix init script
[openwrt/svn-archive/archive.git] / multimedia / uvc-streamer / Makefile
index de8dfee515b96df9995c6170bd9a05dcae665d4d..f49c0213ef132824a3399f1a5279c6fbea8216d4 100644 (file)
@@ -25,11 +25,13 @@ define Package/uvc-streamer
   CATEGORY:=Utilities
   TITLE:=Linux-UVC streaming applicaton
   DEPENDS:=@LINUX_2_6 +libpthread
   CATEGORY:=Utilities
   TITLE:=Linux-UVC streaming applicaton
   DEPENDS:=@LINUX_2_6 +libpthread
-  DESCRIPTION:=\
-  This package contains a streaming daemon for Linux-UVC based webcams
   URL:=http://www.naaa.de/uvc_streamer
 endef
 
   URL:=http://www.naaa.de/uvc_streamer
 endef
 
+define Package/uvc-streamer/description
+       This package contains a streaming daemon for Linux-UVC based webcams
+endef
+
 MAKE_FLAGS += \
        -C $(PKG_BUILD_DIR) \
        CFLAGS="$(TARGET_CFLAGS)" \
 MAKE_FLAGS += \
        -C $(PKG_BUILD_DIR) \
        CFLAGS="$(TARGET_CFLAGS)" \
@@ -38,7 +40,11 @@ MAKE_FLAGS += \
 
 define Package/uvc-streamer/install
        $(INSTALL_DIR) $(1)/sbin
 
 define Package/uvc-streamer/install
        $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/uvc_stream $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/uvc_stream $(1)/sbin/$(PKG_NAME)
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,uvc-streamer))
 endef
 
 $(eval $(call BuildPackage,uvc-streamer))