[package] update to aircrack-ng 1.0 (#6047)
[openwrt/svn-archive/archive.git] / net / aircrack-ng / Makefile
index e1777449d991620d5ad8fecfbe9f2adb29f0e29c..38e4e44d02c0d1c3b96ace66d5cf131dcfad03c2 100644 (file)
@@ -1,33 +1,32 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aircrack-ng
-PKG_VERSION:=0.6.2
+PKG_VERSION:=1.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.aircrack-ng.org/
-PKG_MD5SUM:=0b1a9fb6818822f933336efc9fff316b
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/aircrack-ng
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpthread
-  TITLE:=Aircrack-ng the next generation of aircrack with new features
-  URL:=http://www.aircrack-ng.org
+  DEPENDS:=+libpthread +libopenssl +libpcap
+  TITLE:=next generation of aircrack with new features
+  URL:=http://www.aircrack-ng.org/
+  SUBMENU:=wireless
+endef
+
+define Package/aircrack-ng/description
+Aircrack-ng is the next generation of aircrack with new features
 endef
 
 define Build/Configure
@@ -38,23 +37,19 @@ define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -Wall" \
+               CFLAGS="$(TARGET_CFLAGS) -Wall -Iinclude/ $(TARGET_CPPFLAGS) -D_REVISION=0" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                prefix="/usr" \
-               destdir="$(PKG_INSTALL_DIR)" \
-       all install
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               OSNAME=Linux \
+               all install
 endef
 
 define Package/aircrack-ng/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/aircrack-ng $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/airdecap-ng $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/packetforge-ng $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ivstools $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/kstats $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/aireplay-ng $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/airodump-ng $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/airmon-ng $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,aircrack-ng))