[packages] aircrack-ng: remove obsolete patch (thanks swalker!)
[openwrt/svn-archive/archive.git] / net / aircrack-ng / Makefile
index a0b1267af56ee11d8a73e06bb93de4428b368961..6075dca28723d348a00b7253e97bb36e54695315 100644 (file)
@@ -1,60 +1,55 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aircrack-ng
-PKG_VERSION:=0.6.1
+PKG_VERSION:=1.1
 PKG_RELEASE:=1
-PKG_MD5SUM:=6b85fe925c93c972f3d9f8170dce46c6
 
-PKG_SOURCE_URL:=http://download.aircrack-ng.org/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=http://download.aircrack-ng.org/ \
+       http://archive.aircrack-ng.org/aircrack-ng/$(PKG_VERSION)/
+PKG_MD5SUM:=f7a24ed8fad122c4187d06bfd6f998b4
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/aircrack-ng
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=Aircrack-ng the next generation of aircrack with new features
-  DEPENDS:=+libpthread
-  DESCRIPTION:=Aircrack-ng the next generation of aircrack with new features
-  URL:=http://www.aircrack-ng.org
+  DEPENDS:=+libpthread +libopenssl +libpcap
+  TITLE:=next generation of aircrack with new features
+  URL:=http://www.aircrack-ng.org/
+  SUBMENU:=wireless
+endef
+
+define Package/aircrack-ng/description
+Aircrack-ng is the next generation of aircrack with new features
 endef
 
 define Build/Configure
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -Wall" \
+               CFLAGS="$(TARGET_CFLAGS) -Wall -Iinclude/ $(TARGET_CPPFLAGS) -D_REVISION=0" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                prefix="/usr" \
-               destdir="$(PKG_INSTALL_DIR)" \
-       all install
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               OSNAME=Linux \
+               all install
 endef
 
 define Package/aircrack-ng/install
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/aircrack-ng $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/airdecap-ng $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/arpforge-ng $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ivstools $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/kstats $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/aireplay-ng $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/airodump-ng $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/airmon-ng $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,aircrack-ng))