replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / net / aircrack-ng / Makefile
index f2c8dfb14c37832feadac85f2e450c0ed9e63f29..e1777449d991620d5ad8fecfbe9f2adb29f0e29c 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aircrack-ng
-PKG_VERSION:=0.6
+PKG_VERSION:=0.6.2
 PKG_RELEASE:=1
-PKG_MD5SUM:=6b85fe925c93c972f3d9f8170dce46c6
 
-PKG_SOURCE_URL:=http://download.aircrack-ng.org
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://download.aircrack-ng.org/
+PKG_MD5SUM:=0b1a9fb6818822f933336efc9fff316b
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -24,9 +25,8 @@ include $(INCLUDE_DIR)/package.mk
 define Package/aircrack-ng
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=Aircrack-ng the next generation of aircrack with new features
   DEPENDS:=+libpthread
-  DESCRIPTION:=Aircrack-ng the next generation of aircrack with new features
+  TITLE:=Aircrack-ng the next generation of aircrack with new features
   URL:=http://www.aircrack-ng.org
 endef
 
@@ -45,13 +45,13 @@ define Build/Compile
 endef
 
 define Package/aircrack-ng/install
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/aircrack-ng $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/airdecap-ng $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/arpforge-ng $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/packetforge-ng $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ivstools $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/kstats $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/aireplay-ng $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/airodump-ng $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/airmon-ng $(1)/usr/sbin/