aMule: update to 2.3.1
[openwrt/svn-archive/archive.git] / net / aircrack-ng / Makefile
index 7156b6891cddca702ac0cf6696bcd6caea42d39f..e912dfeed12ad5edebc9d1f9bc1c91574e4d7986 100644 (file)
@@ -1,61 +1,52 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aircrack-ng
-PKG_VERSION:=0.9
-PKG_RELEASE:=1
+PKG_VERSION:=1.1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://download.aircrack-ng.org/
-PKG_MD5SUM:=0fbf52827132d2996fc64afaef19cf68
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://download.aircrack-ng.org/ \
+       http://archive.aircrack-ng.org/aircrack-ng/$(PKG_VERSION)/
+PKG_MD5SUM:=f7a24ed8fad122c4187d06bfd6f998b4
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_PARALLEL:=0
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/aircrack-ng
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpthread
+  DEPENDS:=+libpthread +libopenssl +libpcap
   TITLE:=next generation of aircrack with new features
-  DESCRIPTION:=Aircrack-ng is the next generation of aircrack with new features
   URL:=http://www.aircrack-ng.org/
+  SUBMENU:=wireless
 endef
 
-define Build/Configure
+define Package/aircrack-ng/description
+Aircrack-ng is the next generation of aircrack with new features
 endef
 
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -Wall" \
-               prefix="/usr" \
-               destdir="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) -Wall -Iinclude/ $(TARGET_CPPFLAGS) -D_REVISION=0" \
+       LDFLAGS="$(TARGET_LDFLAGS)" \
+       OSNAME=Linux \
+       prefix="/usr" \
+       sqlite="false" \
+       unstable="true"
 
 define Package/aircrack-ng/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/aircrack-ng $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/airdecap-ng $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/packetforge-ng $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ivstools $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/kstats $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/aireplay-ng $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/airodump-ng $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/airmon-ng $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,aircrack-ng))