packages: add missing conffiles define
[openwrt/svn-archive/archive.git] / net / amwall / Makefile
index f9a4350220dece0a84b17112c9706e4e71bb2ad3..3acf3d4a0d54eda8644584803deee3163c801dba 100644 (file)
@@ -1,24 +1,19 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=amwall
 PKG_VERSION:=0.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.amselinux.net/source/
 PKG_MD5SUM:=a8b6438e7fd9ccadc9f68824ae62349c
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,31 +22,35 @@ define Package/amwall
   CATEGORY:=Network
   DEPENDS:=+libamsel
   TITLE:=PF to iptables
-  URL:=http://www.amselinux.net
+  URL:=http://www.amselinux.net/
+  SUBMENU:=Firewall
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                V= \
-               LDIR=$(PKG_BUILD_DIR) \
+               LDIR="$(PKG_BUILD_DIR)" \
                AMSEL_INCLUDE="$(STAGING_DIR)/usr/include" \
-               OPT_LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               OPT_LDFLAGS="$(TARGET_LDFLAGS)" \
                PREFIX="/usr" \
                CONFIG="$(PKG_BUILD_DIR)/etc/amsel" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               SHELL="/bin/bash" \
                all install
 endef
 
 define Package/amwall/install
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin
-       install -d -m0755 $(1)/etc/amsel
-       $(CP) $(PKG_INSTALL_DIR)/etc/amsel* $(1)/etc
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/amsel
+       $(CP) $(PKG_INSTALL_DIR)/etc/amsel* $(1)/etc/
+endef
+
+define Package/amwall/conffiles
+/etc/amsel/firewall.conf
 endef
 
 $(eval $(call BuildPackage,amwall))