[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / net / amwall / Makefile
index 48c35f5c147a5fb0bd5cd84202d526c89b13f21f..ac9d1cc66070526664cd50584db2a2a643198b21 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,10 +14,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.amselinux.net/source/
 PKG_MD5SUM:=a8b6438e7fd9ccadc9f68824ae62349c
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,6 +23,7 @@ define Package/amwall
   DEPENDS:=+libamsel
   TITLE:=PF to iptables
   URL:=http://www.amselinux.net/
+  SUBMENU:=firewall
 endef
 
 define Build/Compile
@@ -38,7 +34,7 @@ define Build/Compile
                V= \
                LDIR="$(PKG_BUILD_DIR)" \
                AMSEL_INCLUDE="$(STAGING_DIR)/usr/include" \
-               OPT_LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               OPT_LDFLAGS="$(TARGET_LDFLAGS)" \
                PREFIX="/usr" \
                CONFIG="$(PKG_BUILD_DIR)/etc/amsel" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -48,9 +44,9 @@ endef
 
 define Package/amwall/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/amsel
        $(CP) $(PKG_INSTALL_DIR)/etc/amsel* $(1)/etc/
 endef