BitTorrent btpd 0.13 package
[openwrt/svn-archive/archive.git] / net / apache / Makefile
index 4d075f162c87bc8c1e30e229fc8fa15ebd823baf..47dbcd065866c9b004478fbef56f6fba7fc212b4 100644 (file)
@@ -17,7 +17,6 @@ PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://ftp.uni-erlangen.de/pub/mirrors/apache/httpd/ \
                http://apache.imsam.info/httpd/
 PKG_MD5SUM:=d050a49bd7532ec21c6bb593b3473a5d
 PKG_SOURCE_URL:=http://ftp.uni-erlangen.de/pub/mirrors/apache/httpd/ \
                http://apache.imsam.info/httpd/
 PKG_MD5SUM:=d050a49bd7532ec21c6bb593b3473a5d
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -35,22 +34,24 @@ endef
 define Package/apache
   $(call Package/apache/Default)
   MENU=1
 define Package/apache
   $(call Package/apache/Default)
   MENU=1
-  DEPENDS:=+apr +apr-util +zlib +libexpat +libpcre +libopenssl +libsqlite3
+  DEPENDS:=+libapr +libaprutil +zlib +libexpat +libpcre +libopenssl +libsqlite3
 endef
 
 define Package/apache-server
   $(call Package/apache/Default)
   TITLE:=The apache server & and some tools
   DEPENDS:=apache
 endef
 
 define Package/apache-server
   $(call Package/apache/Default)
   TITLE:=The apache server & and some tools
   DEPENDS:=apache
-  DESCRIPTION:=\
-       Take care that you don't include apache at the moment into your image\\\
-       please select it only as module because busybox will override\\\
-       /usr/sbin/httpd. It'll be solved soon. If you need to include this\\\
-       package in the image anyway, remove httpd from busybox\\\
-       (Base system --> Configuration --> Networking Utilities --> httpd).\\\
-       Also you should take care for the initscripts, apache's httpd isn't\\\
-       compatible with the one from busybox, so if you want to use apache\\\
-       for running your webif, you'll need to change the parameters in the\\\
+endef
+
+define Package/apache-server/description
+       Take care that you don't include apache at the moment into your image
+       please select it only as module because busybox will override
+       /usr/sbin/httpd. It'll be solved soon. If you need to include this
+       package in the image anyway, remove httpd from busybox
+       (Base system --> Configuration --> Networking Utilities --> httpd).
+       Also you should take care for the initscripts, apache's httpd isn't
+       compatible with the one from busybox, so if you want to use apache
+       for running your webif, you'll need to change the parameters in the
        scripts and configure the rest in /etc/httpd.conf.
 endef
 
        scripts and configure the rest in /etc/httpd.conf.
 endef
 
@@ -79,9 +80,9 @@ endef
 
 define Build/Configure 
        $(call Build/Configure/Default, \
 
 define Build/Configure 
        $(call Build/Configure/Default, \
-               --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
-               --with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \
-               --with-pcre="$(STAGING_DIR)/usr/bin/pcre-config" \
+               --with-apr="$(STAGING_DIR)/host/bin/apr-1-config" \
+               --with-apr-util="$(STAGING_DIR)/host/bin/apu-1-config" \
+               --with-pcre="$(STAGING_DIR)/host/bin/pcre-config" \
                --enable-http \
                --enable-ssl \
                --enable-proxy \
                --enable-http \
                --enable-ssl \
                --enable-proxy \
@@ -122,14 +123,6 @@ define Build/InstallDev
                $(1)/usr/share
 endef
 
                $(1)/usr/share
 endef
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/{ap_*,http*,mod_*,mpm*,os.h,scoreboard.h,unixd.h,util_*} \
-               $(STAGING_DIR)/etc/{httpd.conf,magic,mime.types,extra,original} \
-               $(STAGING_DIR)/usr/sbin/{ab,apachectl,apxs,checkgid,dbmmanage,envvars,envvars-std,htcacheclean,htdbm,htdigest,htpasswd,httpd,httxt2dbm,logresolve,rotatelogs} \
-               $(STAGING_DIR)/usr/share/{error,icons,htdocs,cgi-bin,build} \
-               $(STAGING_DIR)/usr/lib/httpd.exp
-endef
-
 define Package/apache-server/preinst
        rm /usr/sbin/httpd
        echo -e "You should take a look in the initscripts, busybox's httpd \n\
 define Package/apache-server/preinst
        rm /usr/sbin/httpd
        echo -e "You should take a look in the initscripts, busybox's httpd \n\
@@ -139,7 +132,7 @@ endef
 define Package/apache-server/install
        $(INSTALL_DIR) $(1)/usr/sbin
        # we don't need apxs on the router, it's just for building apache modules.  
 define Package/apache-server/install
        $(INSTALL_DIR) $(1)/usr/sbin
        # we don't need apxs on the router, it's just for building apache modules.  
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{ab,apachectl,checkgid,dbmmanage,envvars,envvars-std,htcacheclean,htdbm,htdigest,htpasswd,httpd,httxt2dbm,logresolve,rotatelogs} $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{ab,apachectl,checkgid,dbmmanage,envvars,envvars-std,htcacheclean,htdbm,htdigest,htpasswd,httpd,httxt2dbm,logresolve,rotatelogs} $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/httpd.exp $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/share
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/httpd.exp $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/share