[packages] apache: remove apache-server and move all server stuff in apache (closes...
[openwrt/svn-archive/archive.git] / net / apache / Makefile
index ea395031a3467f2b254c6f4eb5cd044605c02d7d..5756224c52b99fb9f91f23d473c8f8fc0578016a 100644 (file)
@@ -1,26 +1,23 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$ 
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apache
-PKG_VERSION:=2.2.6
+PKG_VERSION:=2.2.9
 PKG_RELEASE:=2
 PKG_SOURCE_NAME:=httpd
 
-PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://ftp.uni-erlangen.de/pub/mirrors/apache/httpd/ \
                http://apache.imsam.info/httpd/
-PKG_MD5SUM:=d050a49bd7532ec21c6bb593b3473a5d
-PKG_CAT:=zcat
+PKG_MD5SUM:=3afa8137dc1999be695a20b62fdf032b
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,29 +29,34 @@ define Package/apache/Default
   URL:=http://httpd.apache.org/
 endef
 
+define Package/apache/Default/description
+ The Apache Web Server is a powerful and flexible HTTP/1.1 compliant
+ web server.  Originally designed as a replacement for the NCSA HTTP
+ Server, it has grown to be the most popular web server on the Internet.
+endef
+
 define Package/apache
-  $(call Package/apache/Default)
-  MENU=1
-  DEPENDS:=+apr +apr-util +zlib +libexpat +libpcre +libopenssl +libsqlite3
+$(call Package/apache/Default)
+  DEPENDS:=+libapr +libaprutil +zlib +libexpat +libpcre +libopenssl +libsqlite3
 endef
 
-define Package/apache-server
-  $(call Package/apache/Default)
-  TITLE:=The apache server & and some tools
-  DEPENDS:=apache
-  DESCRIPTION:=\
-       Take care that you don't include apache at the moment into your image\\\
-       please select it only as module because busybox will override\\\
-       /usr/sbin/httpd. It'll be solved soon. If you need to include this\\\
-       package in the image anyway, remove httpd from busybox\\\
-       (Base system --> Configuration --> Networking Utilities --> httpd).\\\
-       Also you should take care for the initscripts, apache's httpd isn't\\\
-       compatible with the one from busybox, so if you want to use apache\\\
-       for running your webif, you'll need to change the parameters in the\\\
      scripts and configure the rest in /etc/httpd.conf.
+define Package/apache/description
+$(call Package/apache/Default/description)
+ .
+ This package contains the Apache web server and utility programs.
+ .
+ Take care that you don't include apache at the moment into your image
+ please select it only as module because busybox will override
+ /usr/sbin/httpd. It'll be solved soon. If you need to include this
+ package in the image anyway, remove httpd from busybox
+ (Base system --> Configuration --> Networking Utilities --> httpd).
+ Also you should take care for the initscripts, apache's httpd isn't
+ compatible with the one from busybox, so if you want to use apache
+ for running your webif, you'll need to change the parameters in the
+ scripts and configure the rest in /etc/httpd.conf.
 endef
 
-define Package/apache-server/conffiles
+define Package/apache/conffiles
 /etc/apache/httpd.conf
 /etc/apache/extra/httpd-autoindex.conf
 /etc/apache/extra/httpd-dav.conf
@@ -72,11 +74,17 @@ define Package/apache-server/conffiles
 endef
 
 define Package/apache-icons
-  $(call Package/apache/Default)
+$(call Package/apache/Default)
   TITLE:=Icons from Apache
   DEPENDS:=apache
 endef
 
+define Package/apache-icons/description
+$(call Package/apache/Default/description)
+ .
+ This package contains the icons from Apache.
+endef
+
 define Build/Configure 
        $(call Build/Configure/Default, \
                --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
@@ -105,41 +113,33 @@ define Build/InstallDev
        rm -rf  $(PKG_INSTALL_DIR)/usr/man/ \
                $(PKG_INSTALL_DIR)/usr/share/manual/
        # if you need docs take a look into the build-dir :)
-       mkdir -p $(STAGING_DIR)/etc
+       mkdir -p $(1)/etc
        $(CP)   $(PKG_INSTALL_DIR)/etc/* \
-               $(STAGING_DIR)/etc
-       mkdir -p $(STAGING_DIR)/usr/include
+               $(1)/etc
+       mkdir -p $(1)/usr/include/apache
        $(CP)   $(PKG_INSTALL_DIR)/usr/include/* \
-               $(STAGING_DIR)/usr/include
-       mkdir -p $(STAGING_DIR)/usr/lib
+               $(1)/usr/include/apache
+       mkdir -p $(1)/usr/lib
        $(CP)   $(PKG_INSTALL_DIR)/usr/lib/httpd.exp \
-               $(STAGING_DIR)/usr/lib
-       mkdir -p $(STAGING_DIR)/usr/sbin
+               $(1)/usr/lib
+       mkdir -p $(1)/usr/sbin
        $(CP)   $(PKG_INSTALL_DIR)/usr/sbin/* \
-               $(STAGING_DIR)/usr/sbin
-       mkdir -p $(STAGING_DIR)/usr/share
+               $(1)/usr/sbin
+       mkdir -p $(1)/usr/share
        $(CP)   $(PKG_INSTALL_DIR)/usr/share/* \
-               $(STAGING_DIR)/usr/share
-endef
-
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/{ap_*,http*,mod_*,mpm*,os.h,scoreboard.h,unixd.h,util_*} \
-               $(STAGING_DIR)/etc/{httpd.conf,magic,mime.types,extra,original} \
-               $(STAGING_DIR)/usr/sbin/{ab,apachectl,apxs,checkgid,dbmmanage,envvars,envvars-std,htcacheclean,htdbm,htdigest,htpasswd,httpd,httxt2dbm,logresolve,rotatelogs} \
-               $(STAGING_DIR)/usr/share/{error,icons,htdocs,cgi-bin,build} \
-               $(STAGING_DIR)/usr/lib/httpd.exp
+               $(1)/usr/share
 endef
 
-define Package/apache-server/preinst
+define Package/apache/preinst
        rm /usr/sbin/httpd
        echo -e "You should take a look in the initscripts, busybox's httpd \n\
        uses some parameters which are maybe unsupported by apache."
 endef
 
-define Package/apache-server/install
+define Package/apache/install
        $(INSTALL_DIR) $(1)/usr/sbin
        # we don't need apxs on the router, it's just for building apache modules.  
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{ab,apachectl,checkgid,dbmmanage,envvars,envvars-std,htcacheclean,htdbm,htdigest,htpasswd,httpd,httxt2dbm,logresolve,rotatelogs} $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{ab,apachectl,checkgid,dbmmanage,envvars,envvars-std,htcacheclean,htdbm,htdigest,htpasswd,httpd,httxt2dbm,logresolve,rotatelogs} $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/httpd.exp $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/share
@@ -149,7 +149,7 @@ define Package/apache-server/install
        $(CP) ./files/etc/apache/httpd.conf $(1)/etc/apache/
 endef
 
-define Package/apache-server/postrm
+define Package/apache/postrm
        rm -rf /usr/sbin/httpd
        ln -s /bin/busybox /usr/sbin/httpd
        echo -e "You may need to change your initscripts back for the use \n\
@@ -162,5 +162,4 @@ define Package/apache-icons/install
 endef
 
 $(eval $(call BuildPackage,apache))
-$(eval $(call BuildPackage,apache-server))
 $(eval $(call BuildPackage,apache-icons))