install apache includes into usr/include/apache instead of usr/include - fixes xf86...
[openwrt/svn-archive/archive.git] / net / apache / Makefile
index b468a654be99223797f3f696bb9ca34c314d59ad..f65154f1e0fc87f479d50576f0d795b9635dff8b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,17 +9,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apache
-PKG_VERSION:=2.2.6
-PKG_RELEASE:=2
+PKG_VERSION:=2.2.9
+PKG_RELEASE:=1
 PKG_SOURCE_NAME:=httpd
 
-PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://ftp.uni-erlangen.de/pub/mirrors/apache/httpd/ \
                http://apache.imsam.info/httpd/
-PKG_MD5SUM:=d050a49bd7532ec21c6bb593b3473a5d
+PKG_MD5SUM:=3afa8137dc1999be695a20b62fdf032b
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -37,9 +36,15 @@ define Package/apache
   DEPENDS:=+libapr +libaprutil +zlib +libexpat +libpcre +libopenssl +libsqlite3
 endef
 
+define Package/apache/description
+       The Apache Web Server is a powerful and flexible HTTP/1.1 compliant
+       web server.  Originally designed as a replacement for the NCSA HTTP
+       Server, it has grown to be the most popular web server on the Internet.
+endef
+
 define Package/apache-server
   $(call Package/apache/Default)
-  TITLE:=The apache server & and some tools
+  TITLE:=The Apache Web Server and some tools
   DEPENDS:=apache
 endef
 
@@ -78,10 +83,15 @@ define Package/apache-icons
   DEPENDS:=apache
 endef
 
+define Package/apache-icons/description
+  $(call Package/apache/description)
+  This package contains the icons from Apache.
+endef
+
 define Build/Configure 
        $(call Build/Configure/Default, \
-               --with-apr="$(STAGING_DIR_HOST)/bin/apr-1-config" \
-               --with-apr-util="$(STAGING_DIR_HOST)/bin/apu-1-config" \
+               --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
+               --with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \
                --with-pcre="$(STAGING_DIR)/usr/bin/pcre-config" \
                --enable-http \
                --enable-ssl \
@@ -109,9 +119,9 @@ define Build/InstallDev
        mkdir -p $(1)/etc
        $(CP)   $(PKG_INSTALL_DIR)/etc/* \
                $(1)/etc
-       mkdir -p $(1)/usr/include
+       mkdir -p $(1)/usr/include/apache
        $(CP)   $(PKG_INSTALL_DIR)/usr/include/* \
-               $(1)/usr/include
+               $(1)/usr/include/apache
        mkdir -p $(1)/usr/lib
        $(CP)   $(PKG_INSTALL_DIR)/usr/lib/httpd.exp \
                $(1)/usr/lib
@@ -123,14 +133,6 @@ define Build/InstallDev
                $(1)/usr/share
 endef
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/{ap_*,http*,mod_*,mpm*,os.h,scoreboard.h,unixd.h,util_*} \
-               $(STAGING_DIR)/etc/{httpd.conf,magic,mime.types,extra,original} \
-               $(STAGING_DIR)/usr/sbin/{ab,apachectl,apxs,checkgid,dbmmanage,envvars,envvars-std,htcacheclean,htdbm,htdigest,htpasswd,httpd,httxt2dbm,logresolve,rotatelogs} \
-               $(STAGING_DIR)/usr/share/{error,icons,htdocs,cgi-bin,build} \
-               $(STAGING_DIR)/usr/lib/httpd.exp
-endef
-
 define Package/apache-server/preinst
        rm /usr/sbin/httpd
        echo -e "You should take a look in the initscripts, busybox's httpd \n\