[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / net / arpd / Makefile
index b6e8bff1e31bafae2ca1e6b168ee9fd8e7909e42..88598fe22edf8338aa552bfd4c7df69d31145548 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -43,8 +42,8 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CCOPT="$(TARGET_CFLAGS)" \
-               INCLS="-I. -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LIBS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lpcap -ldnet -levent"
+               INCLS="-I. $(TARGET_CPPFLAGS)" \
+               LIBS="$(TARGET_LDFLAGS) -lpcap -ldnet -levent"
 endef
 
 define Package/arpd/install