[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / net / arpwatch / Makefile
index 1b2ca34423cff0dbff252a26c29f374d3b525439..08724e4b3e423c8df68b99b0eb158064d273c129 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -43,8 +43,8 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                ARPDIR=/etc/arpwatch \
                CCOPT="$(TARGET_CFLAGS)" \
-               INCLS="-I. -I$(STAGING_DIR)/usr/include" \
-               LIBS="-L$(STAGING_DIR)/usr/lib -lpcap"
+               INCLS="-I. $(TARGET_CPPFLAGS)" \
+               LIBS="$(TARGET_LDFLAGS) -lpcap"
 endef
 
 define Package/arpwatch/install