[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / net / arpwatch / Makefile
index 7c17393d1d9210e30e4adfdea97446d03ee2b40b..08724e4b3e423c8df68b99b0eb158064d273c129 100644 (file)
@@ -1,23 +1,19 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=arpwatch
-PKG_VERSION:=2.1a11
+PKG_VERSION:=2.1a15
 PKG_RELEASE:=1
-PKG_MD5SUM:=9ecd00db892737431b0e524f3e52e19e
 
-PKG_SOURCE_URL:=http://nbd.vd-s.ath.cx/openwrt
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=ftp://ftp.free.fr/.mirrors1/ftp.gentoo.org/distfiles/
+PKG_MD5SUM:=cebfeb99c4a7c2a6cee2564770415fe7
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,28 +22,36 @@ define Package/arpwatch
   CATEGORY:=Network
   DEPENDS:=+libpcap
   TITLE:=Ethernet station activity monitor
-  DESCRIPTION:=Ethernet monitor program for keeping track of ethernet/ip address pairings
-  URL:=http://nbd.vd-s.ath.cx/openwrt
+  URL:=http://www-nrg.ee.lbl.gov/
+endef
+
+define Package/arpwatch/description
+       Ethernet monitor program for keeping track of ethernet/ip address
+       pairings.
 endef
 
 define Package/arpwatch/conffiles
 /etc/arpwatch/arp.dat
 endef
 
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       chmod -R u+w $(PKG_BUILD_DIR)
+endef
+
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                ARPDIR=/etc/arpwatch \
                CCOPT="$(TARGET_CFLAGS)" \
-               INCLS="-I. -I$(STAGING_DIR)/usr/include" \
-               LIBS="-L$(STAGING_DIR)/usr/lib -lpcap"
+               INCLS="-I. $(TARGET_CPPFLAGS)" \
+               LIBS="$(TARGET_LDFLAGS) -lpcap"
 endef
 
 define Package/arpwatch/install
-       install -m0755 -d $(1)/usr/sbin $(1)/etc/arpwatch
-       $(CP) $(PKG_BUILD_DIR)/arp{watch,snmp} $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/arpwatch
        $(CP) $(PKG_BUILD_DIR)/arp.dat $(1)/etc/arpwatch/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/arp{watch,snmp} $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,arpwatch))