[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / net / arpwatch / Makefile
index b63f5f8933f661fc9359f63da2642c71446db722..08724e4b3e423c8df68b99b0eb158064d273c129 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -35,12 +34,17 @@ define Package/arpwatch/conffiles
 /etc/arpwatch/arp.dat
 endef
 
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       chmod -R u+w $(PKG_BUILD_DIR)
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                ARPDIR=/etc/arpwatch \
                CCOPT="$(TARGET_CFLAGS)" \
-               INCLS="-I. -I$(STAGING_DIR)/usr/include" \
-               LIBS="-L$(STAGING_DIR)/usr/lib -lpcap"
+               INCLS="-I. $(TARGET_CPPFLAGS)" \
+               LIBS="$(TARGET_LDFLAGS) -lpcap"
 endef
 
 define Package/arpwatch/install