packages/arpwatch: use new service functions
[openwrt/svn-archive/archive.git] / net / arpwatch / Makefile
index b63f5f8933f661fc9359f63da2642c71446db722..20b1959b608a9abd56410924689e04ed7a7a31dd 100644 (file)
@@ -1,21 +1,23 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=arpwatch
 PKG_VERSION:=2.1a15
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.free.fr/.mirrors1/ftp.gentoo.org/distfiles/
 PKG_MD5SUM:=cebfeb99c4a7c2a6cee2564770415fe7
 
+# use a subdirectory to prevent configure for finding libpcap build dir
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/$(PKG_NAME)-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/arpwatch
@@ -35,12 +37,17 @@ define Package/arpwatch/conffiles
 /etc/arpwatch/arp.dat
 endef
 
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       chmod -R u+w $(PKG_BUILD_DIR)
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                ARPDIR=/etc/arpwatch \
                CCOPT="$(TARGET_CFLAGS)" \
-               INCLS="-I. -I$(STAGING_DIR)/usr/include" \
-               LIBS="-L$(STAGING_DIR)/usr/lib -lpcap"
+               INCLS="-I. $(TARGET_CPPFLAGS)" \
+               LIBS="$(TARGET_LDFLAGS) -lpcap"
 endef
 
 define Package/arpwatch/install
@@ -48,6 +55,8 @@ define Package/arpwatch/install
        $(CP) $(PKG_BUILD_DIR)/arp.dat $(1)/etc/arpwatch/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/arp{watch,snmp} $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/arpwatch.init $(1)/etc/init.d/arpwatch
 endef
 
 $(eval $(call BuildPackage,arpwatch))