asterisk-1.4.x: do not install anything into /var
[openwrt/svn-archive/archive.git] / net / asterisk-1.4.x / Makefile
index eb77ac03d3f1b3d37f549f281b8ed1596a267d70..909dacaffbd1cd49f4468364197778dfb19cabba 100644 (file)
@@ -1,20 +1,19 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk
-PKG_VERSION:=1.4.23.1
+PKG_VERSION:=1.4.25.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
-PKG_MD5SUM:=4788954a93f5fbf78e55e2aa6e03329f
+PKG_MD5SUM:=ca17be11559eb939ea16b8de98ddeefb
 
 PKG_BUILD_DEPENDS:= libopenh323 pwlib
 
@@ -334,11 +333,10 @@ define Package/asterisk14-rawplayer/description
 endef
 
 
-#      --with-ltdl="$(STAGING_DIR)/usr" \
 CONFIGURE_ARGS+= \
        --without-curl \
        --without-curses \
-       --with-gsm="$(STAGING_DIR)/usr" \
+       --with-gsm="internal" \
        --without-imap \
        --without-isdnnet \
        --without-kde \
@@ -550,8 +548,7 @@ define Package/asterisk14/install
        rm -rf $(1)/usr/bin
        rm -rf $(1)/usr/man
        rm -rf $(1)/usr/include
-       rm -rf $(1)/var/spool/asterisk/meetme
-       rm -rf $(1)/var/spool/asterisk/voicemail
+       rm -rf $(1)/var
        (cd $(1)/usr/lib/asterisk; \
                rm -rf agi-bin; \
                rm -rf images; \