add required libpopt dependency for asterisk14-mini; fixes #7112
[openwrt/svn-archive/archive.git] / net / asterisk-1.4.x / Makefile
index 1d3fa750ca22e2e7521d51c5cb0e468b17ab75dd..dfddd000c2b2bf994bad3f793592a926b86e9b3e 100644 (file)
@@ -1,20 +1,19 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk
-PKG_VERSION:=1.4.21
-PKG_RELEASE:=1
+PKG_VERSION:=1.4.25.1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.digium.com/pub/asterisk/releases/
-PKG_MD5SUM:=c4cf69eb6eae3105806b08d3efc28ec7
+PKG_MD5SUM:=ca17be11559eb939ea16b8de98ddeefb
 
 PKG_BUILD_DEPENDS:= libopenh323 pwlib
 
@@ -37,6 +36,7 @@ define Package/asterisk14/Default
   SECTION:=net
   CATEGORY:=Network
   URL:=http://www.asterisk.org/
+  MAINTAINER:=Hans Zandbelt <hans.zandbelt@gmail.com>
 endef
 
 define Package/asterisk14/Default/description
@@ -61,7 +61,7 @@ endef
 define Package/asterisk14-mini
 $(call Package/asterisk14/Default)
   TITLE:=Minimal open source PBX
-  DEPENDS:=+libncurses +libpthread @!TARGET_avr32
+  DEPENDS:=+libncurses +libpopt +libpthread @!TARGET_avr32
 endef
 
 define Package/asterisk14-mini/description
@@ -337,11 +337,10 @@ endef
 CONFIGURE_ARGS+= \
        --without-curl \
        --without-curses \
-       --with-gsm="$(STAGING_DIR)/usr" \
+       --with-gsm="internal" \
        --without-imap \
        --without-isdnnet \
        --without-kde \
-       --with-ltdl="$(STAGING_DIR)/usr" \
        --without-misdn \
        --without-nbs \
        --with-ncurses="$(STAGING_DIR)/usr" \
@@ -485,7 +484,7 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include/asterisk/
+       $(INSTALL_DIR) $(1)/usr/include/asterisk/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/asterisk/*.h $(1)/usr/include/asterisk/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/asterisk.h $(1)/usr/include/
 endef
@@ -530,15 +529,15 @@ define Package/asterisk14/conffiles
 /etc/asterisk/users.conf
 endef
 
-define Package/asterisk14/postinst
-#!/bin/sh
-ROOT=`echo $${PKG_ROOT} | sed 's:[\/]:\\\&:g' -`
-/bin/sed -i 's/\ \/etc/\ '$${ROOT}'etc/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
-/bin/sed -i 's/\ \/var/\ '$${ROOT}'var/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
-/bin/sed -i 's/\ \/usr/\ '$${ROOT}'usr/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
-/bin/sed -i 's/^DEST=/DEST='$${ROOT}'/g' $${PKG_ROOT}/etc/init.d/asterisk
-/bin/sed -i 's/OPTIONS=\"\"/OPTIONS=\"-C\ '$${ROOT}'etc\/asterisk\/asterisk.conf\"/g' $${PKG_ROOT}/etc/default/asterisk
-endef
+#define Package/asterisk14/postinst
+##!/bin/sh
+#ROOT=`echo $${PKG_ROOT} | sed 's:[\/]:\\\&:g' -`
+#/bin/sed -i 's/\ \/etc/\ '$${ROOT}'etc/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
+#/bin/sed -i 's/\ \/var/\ '$${ROOT}'var/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
+#/bin/sed -i 's/\ \/usr/\ '$${ROOT}'usr/g' $${PKG_ROOT}/etc/asterisk/asterisk.conf
+#/bin/sed -i 's/^DEST=/DEST='$${ROOT}'/g' $${PKG_ROOT}/etc/init.d/asterisk
+#/bin/sed -i 's/OPTIONS=\"\"/OPTIONS=\"-C\ '$${ROOT}'etc\/asterisk\/asterisk.conf\"/g' $${PKG_ROOT}/etc/default/asterisk
+#endef
 
 define Package/asterisk14/install
        $(CP) $(PKG_INSTALL_DIR)/* $(1)
@@ -550,8 +549,7 @@ define Package/asterisk14/install
        rm -rf $(1)/usr/bin
        rm -rf $(1)/usr/man
        rm -rf $(1)/usr/include
-       rm -rf $(1)/var/spool/asterisk/meetme
-       rm -rf $(1)/var/spool/asterisk/voicemail
+       rm -rf $(1)/var
        (cd $(1)/usr/lib/asterisk; \
                rm -rf agi-bin; \
                rm -rf images; \