packages: add missing conffiles define
[openwrt/svn-archive/archive.git] / net / autossh / Makefile
index b34700bf46644d32a0a01f8232fdddf80142aa5b..70c4c766003acc32a7e9faf7e6db8a2acc054aaf 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=autossh
 PKG_VERSION:=1.4b
-PKG_RELEASE:=1
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.harding.motd.ca/autossh/
@@ -39,6 +39,12 @@ define Package/autossh/install
        $(INSTALL_BIN) ./files/autossh.init $(1)/etc/init.d/autossh
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/autossh.config $(1)/etc/config/autossh
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files/autossh.hotplug $(1)/etc/hotplug.d/iface/20-autossh
+endef
+
+define Package/autossh/conffiles
+/etc/config/autossh
 endef
 
 $(eval $(call BuildPackage,autossh))