[package] autossh: increase reliability of connection behavior
[openwrt/svn-archive/archive.git] / net / autossh / Makefile
index f7a1e81eb81ceed8ee55574205e4d21475d7c6ce..c02c12d0b3506ffaadd2c69ca035d31ba6c6d50b 100644 (file)
@@ -1,45 +1,46 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=autossh
-PKG_VERSION:=1.3
-PKG_RELEASE:=1
+PKG_VERSION:=1.4b
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.harding.motd.ca/autossh/
-PKG_MD5SUM:=0e7ec62eeca5d1b197f3ef2d0f0d417f
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=8f9aa006f6f69e912d3c2f504622d6f7
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/autossh
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+openssh-client
   TITLE:=Autossh client
   URL:=http://www.harding.motd.ca/autossh/
+  SUBMENU:=SSH
 endef
 
 define Build/Compile
-       $(call Build/Compile/Default, -f Makefile.linux \
+       $(call Build/Compile/Default, -f Makefile \
                CFLAGS="$(TARGET_CFLAGS) -Wall -D\"SSH_PATH=\\\"\$$$$(SSH)\\\"\" -D\"VER=\\\"\$$$$(VER)\\\"\"" \
                all \
        )
 endef
 
 define Package/autossh/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/autossh $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/autossh $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/autossh.init $(1)/etc/init.d/autossh
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/autossh.config $(1)/etc/config/autossh
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files/autossh.hotplug $(1)/etc/hotplug.d/iface/20-autossh
 endef
 
 $(eval $(call BuildPackage,autossh))