[package] autossh: increase reliability of connection behavior
[openwrt/svn-archive/archive.git] / net / autossh / Makefile
index f8f47aa57e8e3358994d0cf0877eaea14acbe603..c02c12d0b3506ffaadd2c69ca035d31ba6c6d50b 100644 (file)
@@ -1,23 +1,19 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=autossh
-PKG_VERSION:=1.4a
-PKG_RELEASE:=1
+PKG_VERSION:=1.4b
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.harding.motd.ca/autossh/
-PKG_MD5SUM:=a5497938986f0c179926f1ebba603767
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=8f9aa006f6f69e912d3c2f504622d6f7
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,6 +22,7 @@ define Package/autossh
   CATEGORY:=Network
   TITLE:=Autossh client
   URL:=http://www.harding.motd.ca/autossh/
+  SUBMENU:=SSH
 endef
 
 define Build/Compile
@@ -38,6 +35,12 @@ endef
 define Package/autossh/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/autossh $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/autossh.init $(1)/etc/init.d/autossh
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/autossh.config $(1)/etc/config/autossh
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files/autossh.hotplug $(1)/etc/hotplug.d/iface/20-autossh
 endef
 
 $(eval $(call BuildPackage,autossh))