[patch-team] - tor-alpha new package - Signed-off-by: Jacob Appelbaum <jacob@appelbau...
[openwrt/svn-archive/archive.git] / net / autossh / Makefile
index 191deea8c95e99376c0dc982525969c32f147cf4..c207ffe3e17176e2480ff805f88faea268fc4a19 100644 (file)
@@ -4,13 +4,12 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=autossh
 PKG_VERSION:=1.4b
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.harding.motd.ca/autossh/
@@ -23,7 +22,7 @@ define Package/autossh
   CATEGORY:=Network
   TITLE:=Autossh client
   URL:=http://www.harding.motd.ca/autossh/
-  SUBMENU:=ssh
+  SUBMENU:=SSH
 endef
 
 define Build/Compile
@@ -40,6 +39,8 @@ define Package/autossh/install
        $(INSTALL_BIN) ./files/autossh.init $(1)/etc/init.d/autossh
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/autossh.config $(1)/etc/config/autossh
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files/autossh.hotplug $(1)/etc/hotplug.d/iface/20-autossh
 endef
 
 $(eval $(call BuildPackage,autossh))