batman: cleanup and honor copts, updated to 0.2-rv478 as well
[openwrt/svn-archive/archive.git] / net / batman / Makefile
index d59fc801deef410b71ac3efe94fdf59ab05b9268..1bfd76c57aa46814e3ceb6dc39bd0359d418aa0d 100644 (file)
@@ -4,19 +4,19 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 5624 2006-11-23 00:29:07Z nbd $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=batman-III
-PKG_VERSION:=0.2.0a
+PKG_NAME:=batmand
+PKG_VERSION:=0.2-rv478
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tbz2
-PKG_SOURCE_URL:=http://downloads.open-mesh.net/batman
-PKG_MD5SUM:=d5ac8329633590ed072a6b7ecccacf0b
-PKG_CAT:=bzcat
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)_sources
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)_sources.tgz
+PKG_SOURCE_URL:=http://downloads.open-mesh.net/batman/stable/sources/
+PKG_MD5SUM:=b00ad9603e32c85224d5b19f99126ddf
+PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
@@ -33,18 +33,15 @@ endef
 define Build/Configure
 endef
 
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C "$(PKG_BUILD_DIR)" \
-               $(TARGET_CONFIGURE_OPTS) \
-               NODEBUG=1 \
-               OFLAGS="$(TARGET_CFLAGS)" \
-               UNAME="Linux" \
-               INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
-               STRIP="/bin/true" \
-               batmand install
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       CCFLAGS="$(TARGET_CFLAGS)" \
+       OFLAGS="$(TARGET_CFLAGS)" \
+       NODEBUG=1 \
+       UNAME="Linux" \
+       INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
+       STRIP="/bin/true" \
+       batmand install
 
 define Package/batman/install
        $(INSTALL_DIR) $(1)/usr/sbin