batman: cleanup and honor copts, updated to 0.2-rv478 as well
[openwrt/svn-archive/archive.git] / net / batman / patches / 100-makefile.patch
index b96541f74205b625db8f35b0d5ffb1cb8f4320ac..a46a59475085b2fa07575b5180bd8a0b59de8a01 100644 (file)
@@ -1,18 +1,20 @@
---- batman-III-0.2.0a.old/Makefile     2007-02-28 15:41:11.000000000 +0100
-+++ batman-III-0.2.0a/Makefile 2007-02-28 15:42:02.000000000 +0100
-@@ -27,6 +27,7 @@
- CFLAGS =              -Wall -O0 -g3
- LDFLAGS =             -lpthread
- #LDFLAGS =            -static -lpthread
-+SBINDIR =      $(INSTALL_PREFIX)/usr/sbin
+Index: batmand_0.2-rv478_sources/Makefile
+===================================================================
+--- batmand_0.2-rv478_sources.orig/Makefile    2007-07-31 14:26:18.000000000 -0500
++++ batmand_0.2-rv478_sources/Makefile 2007-07-31 14:28:43.000000000 -0500
+@@ -21,6 +21,7 @@
+ CFLAGS =              -Wall -O1 -g3 -DDEBUG_MALLOC -DMEMORY_USAGE -DPROFILE_DATA
+ STRIP=                        strip
+ LDFLAGS =             -lpthread -static
++SBINDIR =             $(INSTALL_PREFIX)/usr/sbin
  
  
- UNAME=$(shell uname)
+ CFLAGS_MIPS = -Wall -O1 -g3
+ LDFLAGS_MIPS =        -lpthread
+@@ -264,3 +265,7 @@
  
  
-@@ -67,3 +68,7 @@
- clean:
-               rm -f batmand batmand-mips* *.o *~
+ clean-long:
+               rm -rf batmand_*
 +
 +install:
 +              mkdir -p $(SBINDIR)
 +
 +install:
 +              mkdir -p $(SBINDIR)
-+              install -m 755 batmand $(SBINDIR)
++              install -m 0755 batmand $(SBINDIR)