[package] add a config file and init script to mini_snmpd (#5496)
[openwrt/svn-archive/archive.git] / net / bind / Makefile
index 0d40d7e50d24dbe15ebe0cb296d3fdb012a2293a..5432bf799039736e6454b4e0c1e2e45d41d25d63 100644 (file)
@@ -1,25 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.4.1
-PKG_RELEASE:=1
+PKG_VERSION:=9.5.0-P1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
        ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_MD5SUM:=09b54d35036cb0423b2e618f21766285
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=a4f9dd6d205d24ec89fa4e44d8188197
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,7 +24,7 @@ define Package/bind/Default
   CATEGORY:=Network
   DEPENDS:=+bind-libs +libopenssl
   TITLE:=bind
-  URL:=http://www.isc.org/sw/bind/
+  URL:=https://www.isc.org/software/bind
   SUBMENU:=DNS
 endef
 
@@ -90,6 +86,7 @@ CONFIGURE_ARGS += \
                --disable-threads \
                --with-openssl="$(STAGING_DIR)/usr" \
                --with-libtool \
+               --with-libxml2=no \
                , \
                BUILD_CC="$(TARGET_CC)" \