[packages] asterisk-*: allow headers for multiple versions to co-exist in staging
[openwrt/svn-archive/archive.git] / net / bind / Makefile
index b8437328ac716900f44c6442ab80434a47715a6d..7406d9a3e9d79d855f52af107fe735a6eab319a2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.6.1-P2
+PKG_VERSION:=9.7.2-P3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
        ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_MD5SUM:=435bc2e26e470d46ddf2acb24abb6ea6
+PKG_MD5SUM:=b4537cbae38b2daef36775bf49f33db9
+
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -79,19 +81,19 @@ endef
 export BUILD_CC="$(TARGET_CC)"
 
 CONFIGURE_ARGS += \
-               --enable-shared \
-               --enable-static \
-               --with-randomdev="/dev/urandom" \
-               --disable-threads \
-               --with-openssl="$(STAGING_DIR)/usr" \
-               --with-libtool \
-               --with-libxml2=no \
-               , \
-               BUILD_CC="$(TARGET_CC)" \
+       --enable-shared \
+       --enable-static \
+       --with-randomdev="/dev/urandom" \
+       --disable-threads \
+       --with-openssl="$(STAGING_DIR)/usr" \
+       --with-libtool \
+       --with-libxml2=no \
+       --enable-epoll=yes \
+
+CONFIGURE_VARS += \
+       BUILD_CC="$(TARGET_CC)" \
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR)/lib/dns \
                BUILD_CC="$(HOSTCC)" \
                CC="$(HOSTCC)" \