[packages] asterisk-*: allow headers for multiple versions to co-exist in staging
[openwrt/svn-archive/archive.git] / net / bind / Makefile
index d91c33766a21491af5d7a6fba92df03f1e0a96e7..7406d9a3e9d79d855f52af107fe735a6eab319a2 100644 (file)
@@ -1,25 +1,23 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.4.1
+PKG_VERSION:=9.7.2-P3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
        ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_MD5SUM:=09b54d35036cb0423b2e618f21766285
+PKG_MD5SUM:=b4537cbae38b2daef36775bf49f33db9
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,7 +26,7 @@ define Package/bind/Default
   CATEGORY:=Network
   DEPENDS:=+bind-libs +libopenssl
   TITLE:=bind
-  URL:=http://www.isc.org/sw/bind/
+  URL:=https://www.isc.org/software/bind
   SUBMENU:=DNS
 endef
 
@@ -54,7 +52,7 @@ define Package/bind-tools
   $(call Package/bind/Default)
   TITLE+= administration tools (all)
 endef
-  
+
 define Package/bind-rndc
   $(call Package/bind/Default)
   TITLE+= administration tools (rndc and rndc-confgen only)
@@ -83,19 +81,19 @@ endef
 export BUILD_CC="$(TARGET_CC)"
 
 CONFIGURE_ARGS += \
-               --enable-shared \
-               --enable-static \
-               --enable-ipv6 \
-               --with-randomdev="/dev/urandom" \
-               --disable-threads \
-               --with-openssl="$(STAGING_DIR)/usr" \
-               --with-libtool \
-               , \
-               BUILD_CC="$(TARGET_CC)" \
+       --enable-shared \
+       --enable-static \
+       --with-randomdev="/dev/urandom" \
+       --disable-threads \
+       --with-openssl="$(STAGING_DIR)/usr" \
+       --with-libtool \
+       --with-libxml2=no \
+       --enable-epoll=yes \
+
+CONFIGURE_VARS += \
+       BUILD_CC="$(TARGET_CC)" \
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR)/lib/dns \
                BUILD_CC="$(HOSTCC)" \
                CC="$(HOSTCC)" \
@@ -103,7 +101,6 @@ define Build/Compile
                LIBS="" \
                gen
        $(MAKE) -C $(PKG_BUILD_DIR) \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
@@ -119,7 +116,7 @@ define Package/bind-server/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) ./files/bind $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(CP) ./files/named.init $(1)/etc/init.d/named
+       $(INSTALL_BIN) ./files/named.init $(1)/etc/init.d/named
        find $(1)/etc/bind/ -name ".svn" | xargs rm -rf
 endef