[package] bump bind release number after r17835
[openwrt/svn-archive/archive.git] / net / bind / Makefile
index dbd5f9a32b35e31202898c05c582191888233bee..a9e1365bd0f28330ee28c856e1ed8318195069e5 100644 (file)
@@ -1,25 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.5.0-P1
-PKG_RELEASE:=1
+PKG_VERSION:=9.6.1-P1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
        ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_MD5SUM:=a4f9dd6d205d24ec89fa4e44d8188197
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=e6ce3b355c4e6bf5d66ef100f555da3f
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,7 +24,7 @@ define Package/bind/Default
   CATEGORY:=Network
   DEPENDS:=+bind-libs +libopenssl
   TITLE:=bind
-  URL:=http://www.isc.org/sw/bind/
+  URL:=https://www.isc.org/software/bind
   SUBMENU:=DNS
 endef
 
@@ -54,7 +50,7 @@ define Package/bind-tools
   $(call Package/bind/Default)
   TITLE+= administration tools (all)
 endef
-  
+
 define Package/bind-rndc
   $(call Package/bind/Default)
   TITLE+= administration tools (rndc and rndc-confgen only)
@@ -85,7 +81,6 @@ export BUILD_CC="$(TARGET_CC)"
 CONFIGURE_ARGS += \
                --enable-shared \
                --enable-static \
-               --enable-ipv6 \
                --with-randomdev="/dev/urandom" \
                --disable-threads \
                --with-openssl="$(STAGING_DIR)/usr" \
@@ -104,7 +99,6 @@ define Build/Compile
                LIBS="" \
                gen
        $(MAKE) -C $(PKG_BUILD_DIR) \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef