[packages] bind: fix pid file path (#7218)
[openwrt/svn-archive/archive.git] / net / bind / Makefile
index a5bad70a78614e111a9d40e2379c7239be0a8b59..bc9b21c9f57b335bc00c57511cd45dea629a4a32 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.5.0-P1
-PKG_RELEASE:=3
+PKG_VERSION:=9.6.1-P2
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
        ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_MD5SUM:=a4f9dd6d205d24ec89fa4e44d8188197
+PKG_MD5SUM:=435bc2e26e470d46ddf2acb24abb6ea6
+
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -50,7 +52,7 @@ define Package/bind-tools
   $(call Package/bind/Default)
   TITLE+= administration tools (all)
 endef
-  
+
 define Package/bind-rndc
   $(call Package/bind/Default)
   TITLE+= administration tools (rndc and rndc-confgen only)
@@ -90,8 +92,6 @@ CONFIGURE_ARGS += \
                BUILD_CC="$(TARGET_CC)" \
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR)/lib/dns \
                BUILD_CC="$(HOSTCC)" \
                CC="$(HOSTCC)" \
@@ -99,7 +99,6 @@ define Build/Compile
                LIBS="" \
                gen
        $(MAKE) -C $(PKG_BUILD_DIR) \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef