Update bind to 9.5.0 p1 (#3744)
[openwrt/svn-archive/archive.git] / net / bind / Makefile
index 565449b3c009455fb63ece3181cbdbe9ad3b790a..dbd5f9a32b35e31202898c05c582191888233bee 100644 (file)
@@ -9,29 +9,27 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.4.1
+PKG_VERSION:=9.5.0-P1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
        ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_MD5SUM:=09b54d35036cb0423b2e618f21766285
+PKG_MD5SUM:=a4f9dd6d205d24ec89fa4e44d8188197
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-PKG_BUILD_DEPENDS:=libopenssl
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/bind/Default
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+bind-libs
+  DEPENDS:=+bind-libs +libopenssl
   TITLE:=bind
   URL:=http://www.isc.org/sw/bind/
-  SUBMENU:=dns
+  SUBMENU:=DNS
 endef
 
 define Package/bind-libs
@@ -39,7 +37,7 @@ define Package/bind-libs
   CATEGORY:=Network
   TITLE:=bind shared libraries
   URL:=http://www.isc.org/sw/bind/
-  SUBMENU:=dns
+  SUBMENU:=DNS
 endef
 
 define Package/bind-server
@@ -92,6 +90,7 @@ CONFIGURE_ARGS += \
                --disable-threads \
                --with-openssl="$(STAGING_DIR)/usr" \
                --with-libtool \
+               --with-libxml2=no \
                , \
                BUILD_CC="$(TARGET_CC)" \
 
@@ -121,7 +120,7 @@ define Package/bind-server/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) ./files/bind $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(CP) ./files/named.init $(1)/etc/init.d/named
+       $(INSTALL_BIN) ./files/named.init $(1)/etc/init.d/named
        find $(1)/etc/bind/ -name ".svn" | xargs rm -rf
 endef