Update bind to 9.5.0 p1 (#3744)
[openwrt/svn-archive/archive.git] / net / bind / patches / 100-cross_compile.patch
index c8187c62aaaf8689de96f8da94ac4c89b512cae0..47fd61bddb64f9320dd1d2f0096f0cf23bd4c45d 100644 (file)
@@ -1,35 +1,29 @@
-diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
---- bind-9.3.1/configure       2004-12-09 05:09:03.000000000 +0100
-+++ bind-9.3.1.new/configure   2006-07-31 14:24:19.000000000 +0200
-@@ -4750,7 +4750,7 @@
-   use_openssl="auto"
- fi;
--openssldirs="/usr /usr/local /usr/local/ssl /usr/pkg"
-+openssldirs="-I$STAGING_DIR/usr/include"
- if test "$use_openssl" = "auto"
- then
-       for d in $openssldirs
-@@ -5289,6 +5289,7 @@
- if eval "test \"\${$as_ac_File+set}\" = set"; then
-   echo $ECHO_N "(cached) $ECHO_C" >&6
+Index: bind-9.5.0-P1/configure
+===================================================================
+--- bind-9.5.0-P1.orig/configure       2008-05-06 02:33:33.000000000 +0100
++++ bind-9.5.0-P1/configure    2008-07-12 08:23:25.000000000 +0100
+@@ -6369,8 +6369,7 @@
  else
-+cross_compiling=no
    test "$cross_compiling" = yes &&
    { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
- echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
-@@ -23675,175 +23676,6 @@
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+-   { (exit 1); exit 1; }; }
++echo "$as_me: error: cannot check for file existence when cross compiling" >&2;} }
+ if test -r "$devrandom"; then
+   eval "$as_ac_File=yes"
+ else
+@@ -25119,195 +25118,6 @@
  # which provides some (all?) of the desired functions.
  #
  
--echo "$as_me:$LINENO: checking for inet_ntop with IPv6 support" >&5
--echo $ECHO_N "checking for inet_ntop with IPv6 support... $ECHO_C" >&6
+-echo "$as_me:$LINENO: checking for inet_ntop with IPv6 support" >&5
+-echo $ECHO_N "checking for inet_ntop with IPv6 support... $ECHO_C" >&6; }
 -if test "$cross_compiling" = yes; then
--  { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
--See \`config.log' for more details." >&5
--echo "$as_me: error: cannot run test program while cross compiling
--See \`config.log' for more details." >&2;}
--   { (exit 1); exit 1; }; }
+-  { echo "$as_me:$LINENO: result: assuming inet_ntop needed" >&5
+-echo "${ECHO_T}assuming inet_ntop needed" >&6; }
+-      ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
+-      ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
+-      ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
 -else
 -  cat >conftest.$ac_ext <<_ACEOF
 -/* confdefs.h.  */
@@ -46,44 +40,55 @@ diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
 -char a[16],b[64]; return(inet_ntop(AF_INET6, a, b, sizeof(b)) == (char*)0);}
 -_ACEOF
 -rm -f conftest$ac_exeext
--if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
--  (eval $ac_link) 2>&5
+-if { (ac_try="$ac_link"
+-case "(($ac_try" in
+-  *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+-  *) ac_try_echo=$ac_try;;
+-esac
+-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+-  (eval "$ac_link") 2>&5
 -  ac_status=$?
 -  echo "$as_me:$LINENO: \$? = $ac_status" >&5
 -  (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
--  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
--  (eval $ac_try) 2>&5
+-  { (case "(($ac_try" in
+-  *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+-  *) ac_try_echo=$ac_try;;
+-esac
+-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+-  (eval "$ac_try") 2>&5
 -  ac_status=$?
 -  echo "$as_me:$LINENO: \$? = $ac_status" >&5
 -  (exit $ac_status); }; }; then
--  echo "$as_me:$LINENO: result: yes" >&5
--echo "${ECHO_T}yes" >&6
--        ISC_PLATFORM_NEEDNTOP="#undef ISC_PLATFORM_NEEDNTOP"
+-  echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6; }
+-      ISC_PLATFORM_NEEDNTOP="#undef ISC_PLATFORM_NEEDNTOP"
 -else
 -  echo "$as_me: program exited with status $ac_status" >&5
 -echo "$as_me: failed program was:" >&5
 -sed 's/^/| /' conftest.$ac_ext >&5
 -
 -( exit $ac_status )
--echo "$as_me:$LINENO: result: no" >&5
--echo "${ECHO_T}no" >&6
--        ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
--        ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
--        ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
+-echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6; }
+-      ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
+-      ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
+-      ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
 -fi
--rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
+-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
 -fi
 -
 -
+-
+-
 -# On NetBSD 1.4.2 and maybe others, inet_pton() incorrectly accepts
 -# addresses with less than four octets, like "1.2.3".  Also leading
 -# zeros should also be rejected.
 -
--echo "$as_me:$LINENO: checking for working inet_pton with IPv6 support" >&5
--echo $ECHO_N "checking for working inet_pton with IPv6 support... $ECHO_C" >&6
+-echo "$as_me:$LINENO: checking for working inet_pton with IPv6 support" >&5
+-echo $ECHO_N "checking for working inet_pton with IPv6 support... $ECHO_C" >&6; }
 -if test "$cross_compiling" = yes; then
--  echo "$as_me:$LINENO: result: assuming target platform has working inet_pton" >&5
--echo "${ECHO_T}assuming target platform has working inet_pton" >&6
+-  echo "$as_me:$LINENO: result: assuming target platform has working inet_pton" >&5
+-echo "${ECHO_T}assuming target platform has working inet_pton" >&6; }
 -      ISC_PLATFORM_NEEDPTON="#undef ISC_PLATFORM_NEEDPTON"
 -else
 -  cat >conftest.$ac_ext <<_ACEOF
@@ -102,36 +107,47 @@ diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
 -                           (inet_pton(AF_INET6, "::1.2.3.4", a) != 1)); }
 -_ACEOF
 -rm -f conftest$ac_exeext
--if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
--  (eval $ac_link) 2>&5
+-if { (ac_try="$ac_link"
+-case "(($ac_try" in
+-  *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+-  *) ac_try_echo=$ac_try;;
+-esac
+-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+-  (eval "$ac_link") 2>&5
 -  ac_status=$?
 -  echo "$as_me:$LINENO: \$? = $ac_status" >&5
 -  (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
--  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
--  (eval $ac_try) 2>&5
+-  { (case "(($ac_try" in
+-  *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+-  *) ac_try_echo=$ac_try;;
+-esac
+-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+-  (eval "$ac_try") 2>&5
 -  ac_status=$?
 -  echo "$as_me:$LINENO: \$? = $ac_status" >&5
 -  (exit $ac_status); }; }; then
--  echo "$as_me:$LINENO: result: yes" >&5
--echo "${ECHO_T}yes" >&6
--        ISC_PLATFORM_NEEDPTON="#undef ISC_PLATFORM_NEEDPTON"
+-  echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6; }
+-      ISC_PLATFORM_NEEDPTON="#undef ISC_PLATFORM_NEEDPTON"
 -else
 -  echo "$as_me: program exited with status $ac_status" >&5
 -echo "$as_me: failed program was:" >&5
 -sed 's/^/| /' conftest.$ac_ext >&5
 -
 -( exit $ac_status )
--echo "$as_me:$LINENO: result: no" >&5
--echo "${ECHO_T}no" >&6
--        ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_pton.$O"
--        ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_pton.c"
--        ISC_PLATFORM_NEEDPTON="#define ISC_PLATFORM_NEEDPTON 1"
+-echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6; }
+-      ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_pton.$O"
+-      ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_pton.c"
+-      ISC_PLATFORM_NEEDPTON="#define ISC_PLATFORM_NEEDPTON 1"
 -fi
--rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
+-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
 -fi
 -
--echo "$as_me:$LINENO: checking for inet_aton" >&5
--echo $ECHO_N "checking for inet_aton... $ECHO_C" >&6
+-
+-
+-{ echo "$as_me:$LINENO: checking for inet_aton" >&5
+-echo $ECHO_N "checking for inet_aton... $ECHO_C" >&6; }
 -cat >conftest.$ac_ext <<_ACEOF
 -/* confdefs.h.  */
 -_ACEOF
@@ -151,70 +167,56 @@ diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
 -}
 -_ACEOF
 -rm -f conftest.$ac_objext conftest$ac_exeext
--if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
--  (eval $ac_link) 2>conftest.er1
+-if { (ac_try="$ac_link"
+-case "(($ac_try" in
+-  *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+-  *) ac_try_echo=$ac_try;;
+-esac
+-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
+-  (eval "$ac_link") 2>conftest.er1
 -  ac_status=$?
 -  grep -v '^ *+' conftest.er1 >conftest.err
 -  rm -f conftest.er1
 -  cat conftest.err >&5
 -  echo "$as_me:$LINENO: \$? = $ac_status" >&5
--  (exit $ac_status); } &&
--       { ac_try='test -z "$ac_c_werror_flag"
--                       || test ! -s conftest.err'
--  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
--  (eval $ac_try) 2>&5
--  ac_status=$?
--  echo "$as_me:$LINENO: \$? = $ac_status" >&5
--  (exit $ac_status); }; } &&
--       { ac_try='test -s conftest$ac_exeext'
--  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
--  (eval $ac_try) 2>&5
--  ac_status=$?
--  echo "$as_me:$LINENO: \$? = $ac_status" >&5
--  (exit $ac_status); }; }; then
--  echo "$as_me:$LINENO: result: yes" >&5
--echo "${ECHO_T}yes" >&6
--        ISC_PLATFORM_NEEDATON="#undef ISC_PLATFORM_NEEDATON"
+-  (exit $ac_status); } && {
+-       test -z "$ac_c_werror_flag" ||
+-       test ! -s conftest.err
+-       } && test -s conftest$ac_exeext &&
+-       $as_test_x conftest$ac_exeext; then
+-  { echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6; }
+-      ISC_PLATFORM_NEEDATON="#undef ISC_PLATFORM_NEEDATON"
 -else
 -  echo "$as_me: failed program was:" >&5
 -sed 's/^/| /' conftest.$ac_ext >&5
 -
--echo "$as_me:$LINENO: result: no" >&5
--echo "${ECHO_T}no" >&6
--        ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_aton.$O"
--        ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_aton.c"
--        ISC_PLATFORM_NEEDATON="#define ISC_PLATFORM_NEEDATON 1"
+-      { echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6; }
+-      ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_aton.$O"
+-      ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_aton.c"
+-      ISC_PLATFORM_NEEDATON="#define ISC_PLATFORM_NEEDATON 1"
 -fi
--rm -f conftest.err conftest.$ac_objext \
+-
+-rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
 -      conftest$ac_exeext conftest.$ac_ext
 -
 -
 -
 -
+-
  #
  # Look for a 4.4BSD-style sa_len member in struct sockaddr.
-diff -urN bind-9.3.1/configure.in bind-9.3.1.new/configure.in
---- bind-9.3.1/configure.in    2004-12-09 05:07:10.000000000 +0100
-+++ bind-9.3.1.new/configure.in        2006-07-31 14:16:55.000000000 +0200
-@@ -362,7 +362,7 @@
-                           (Required for DNSSEC)],
-     use_openssl="$withval", use_openssl="auto")
--openssldirs="/usr /usr/local /usr/local/ssl /usr/pkg"
-+openssldirs="$STAGING_DIR/usr/include $STAGING_DIR/include"
- if test "$use_openssl" = "auto"
- then
-       for d in $openssldirs
-diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
---- bind-9.3.1/lib/bind/configure      2004-12-09 05:09:03.000000000 +0100
-+++ bind-9.3.1.new/lib/bind/configure  2006-07-31 14:24:19.000000000 +0200
-@@ -5289,6 +5289,7 @@
- if eval "test \"\${$as_ac_File+set}\" = set"; then
+ #
+Index: bind-9.5.0-P1/lib/bind/configure
+===================================================================
+--- bind-9.5.0-P1.orig/lib/bind/configure      2008-04-29 00:51:46.000000000 +0100
++++ bind-9.5.0-P1/lib/bind/configure   2008-06-08 15:16:17.000000000 +0100
+@@ -5292,6 +5292,7 @@
+ if { as_var=$as_ac_File; eval "test \"\${$as_var+set}\" = set"; }; then
    echo $ECHO_N "(cached) $ECHO_C" >&6
  else
 +cross_compiling=no
    test "$cross_compiling" = yes &&
    { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
  echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
-