fix screen compile error
[openwrt/svn-archive/archive.git] / net / bmon / Makefile
index 06e8509cd905006b9573834d39ef4bedddd5078f..0f5f0aaa789156c39befb450f4584091861f8443 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -17,7 +18,6 @@ PKG_MD5SUM:=3111a027907016c0902d67350c619df6
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -43,15 +43,13 @@ define Build/Configure
        )
 endef
 
-
 define Build/Compile
        $(call Build/Compile/Default,all)
 endef
 
 define Package/bmon/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/src/bmon $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/bmon $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,bmon))
-