remove PKG_CAT from packages
[openwrt/svn-archive/archive.git] / net / bmon / Makefile
index 1e0d75dec6721587c0592c9208cf2c57c3fceb15..b4cb327cdc62ecc04af414c4a857efd4f0f8862f 100644 (file)
@@ -1,9 +1,10 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4603 2006-08-18 21:21:06Z mbm $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -14,10 +15,8 @@ PKG_RELEASE:=0
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://people.suug.ch/~tgr/bmon/files/
 PKG_MD5SUM:=3111a027907016c0902d67350c619df6
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,30 +25,32 @@ define Package/bmon
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=bmon is a portable bandwidth monitor
-  DESCRIPTION:=\
-       bmon is a portable bandwidth monitor\\\
-       and rate estimator running on various\\\
-       operating systems. It supports various\\\
-       input methods for different architectures.
   URL:=http://people.suug.ch/~tgr/bmon/
 endef
 
+define Package/bmon/description
+       bmon is a portable bandwidth monitor 
+       and rate estimator running on various 
+       operating systems. It supports various 
+       input methods for different architectures.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
-               --disable-cnt-workaroun \
+               --disable-cnt-workaround \
+               --disable-dbi \
                --disable-rrd \
-               --disable-asoun \
+               --disable-asound \
        )
 endef
 
-
 define Build/Compile
-$(call Build/Compile/Default,all)
+       $(call Build/Compile/Default,all)
 endef
 
 define Package/bmon/install
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/src/bmon $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/bmon $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,bmon))