[packages] tor-alpha: update to 0.2.2.22-alpha, add archive mirror
[openwrt/svn-archive/archive.git] / net / chillispot / Makefile
index b980b0a39d8f5626063c5f26a4446029a3042d44..f55253001b7c3d4ab8f4b5af7e99604cc305b812 100644 (file)
@@ -1,41 +1,42 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=chillispot
 PKG_VERSION:=1.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.chillispot.org/download
+PKG_SOURCE_URL:=http://www.chillispot.info/download
 PKG_MD5SUM:=9d2597756af3fa14d7331b4a3651fc9b
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/chillispot
+  SUBMENU:=Captive Portals
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=@+PACKAGE_KMOD_TUN
+  DEPENDS:=+kmod-tun
   TITLE:=Wireless LAN HotSpot controller
-  DESCRIPTION:=\
-       ChilliSpot is an open source captive portal or wireless LAN \\\
-       access point controller. It is used for authenticating users \\\
-       of a wireless LAN. It supports web based login which is today's \\\
-       standard for public HotSpots and it supports Wireless Protected \\\
-       Access (WPA) which is the standard of the future. Authentication, \\\
-       authorization and accounting (AAA) is handled by your favorite \\\
+  URL:=http://www.chillispot.info/
+endef
+
+define Package/chillispot/description
+       ChilliSpot is an open source captive portal or wireless LAN 
+       access point controller. It is used for authenticating users 
+       of a wireless LAN. It supports web based login which is today's 
+       standard for public HotSpots and it supports Wireless Protected 
+       Access (WPA) which is the standard of the future. Authentication, 
+       authorization and accounting (AAA) is handled by your favorite 
        radius server.
-  URL:=http://www.chillispot.org/
 endef
 
 define Package/chillispot/conffiles
@@ -44,19 +45,13 @@ endef
 
 # uses GNU configure
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Package/chillispot/install
-       install -m0755 -d $(1)/etc/init.d
-       install -m0755 ./files/$(PKG_NAME).init $(1)/etc/init.d/chilli
-       install -m0755 -d $(1)/etc
-       install -m0644 $(PKG_BUILD_DIR)/doc/chilli.conf $(1)/etc/
-       install -m0755 -d $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/chilli $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/chilli
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/doc/chilli.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/chilli $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,chillispot))