[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / net / click / Makefile
index dae1f1c354cf10d4297d9f53367259fed16df72f..4390ee93714c8135053562dc6e35cbc0748709da 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,10 +16,6 @@ ROOFNET_VERSION:=0.0.1
 
 PKG_SOURCE_URL:=http://pdos.csail.mit.edu/~jbicket/click_snapshots/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,19 +25,25 @@ define Package/click
   DEPENDS:=@BROKEN
   MENU:=1
   TITLE:=The Click Modular Router
-  DESCRIPTION:=The Click Modular Router
   URL:=http://www.read.cs.ucla.edu/click/
 endef
 
+define Package/click/description
+The Click Modular Router
+endef
+
 define Package/roofnet
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=@BROKEN click
   TITLE:=roofnet mesh networking scripts
-  DESCRIPTION:=roofnet mesh networking scripts
   URL:=http://pdos.csail.mit.edu/roofnet/
 endef
 
+define Package/roofnet/description
+roofnet mesh networking scripts
+endef
+
 BUILDOPTS = \
                BUILD_CXX="g++ -I $(PKG_BUILD_DIR)/include-host" \
                BUILD_DL_LIBS="-ldl"
@@ -55,10 +57,10 @@ define Build/Configure
                $(CP) include include-host; \
                rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
-               CXXFLAGS="-static -O2 -MD" \
+               CXXFLAGS="-static -Os -MD" \
                CFLAGS="-static -MD" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                $(BUILDOPTS) \
                ./configure \
                  --prefix=/usr \