[packages] nano: update to 2.2.2
[openwrt/svn-archive/archive.git] / net / click / Makefile
index cfa49e835431153674ae89a5a7cce049d4b4c04e..e380e84f1e2bcc2cc2aa08c53950f4c1374596f0 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,47 +16,52 @@ ROOFNET_VERSION:=0.0.1
 
 PKG_SOURCE_URL:=http://pdos.csail.mit.edu/~jbicket/click_snapshots/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/click
   SECTION:=net
   CATEGORY:=Network
+  DEPENDS:=@BROKEN
   MENU:=1
   TITLE:=The Click Modular Router
-  DESCRIPTION:=The Click Modular Router
-  URL:=http://pdos.csail.mit.edu/click/
+  URL:=http://www.read.cs.ucla.edu/click/
+endef
+
+define Package/click/description
+The Click Modular Router
 endef
 
 define Package/roofnet
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=click
+  DEPENDS:=@BROKEN click
   TITLE:=roofnet mesh networking scripts
-  DESCRIPTION:=roofnet mesh networking scripts
   URL:=http://pdos.csail.mit.edu/roofnet/
 endef
 
-CONF_OPTS= \
-               ac_cv_int64_t=no \
-               ac_cv_sizeof_off_t=4
+define Package/roofnet/description
+roofnet mesh networking scripts
+endef
+
+BUILDOPTS = \
+               BUILD_CXX="g++ -I $(PKG_BUILD_DIR)/include-host" \
+               BUILD_DL_LIBS="-ldl"
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
-               $(CONF_OPTS) \
+               rm -rf config.{cache,status} ; \
+               CONFIG_SITE= \
                ./configure; \
-               cp include/click/config.h include/click/config-host.h; \
+               rm -rf include-host; \
+               $(CP) include include-host; \
                rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
-               CXXFLAGS="-static -O2 -MD" \
+               CXXFLAGS="-static -Os -MD" \
                CFLAGS="-static -MD" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               $(CONF_OPTS) \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               $(BUILDOPTS) \
                ./configure \
                  --prefix=/usr \
                  --target=$(GNU_TARGET_NAME) \
@@ -75,7 +80,7 @@ define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
        $(CONF_OPTS) \
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               BUILD_CXX="g++ -include $(PKG_BUILD_DIR)/include/click/config-host.h" \
+               $(BUILDOPTS) \
                tools elementmap.xml
        (cd $(PKG_BUILD_DIR)/userlevel; \
                ../tools/click-mkmindriver/click-mkmindriver -p roofnet -C .. \
@@ -86,19 +91,19 @@ define Build/Compile
 endef
 
 define Package/click/install
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/userlevel/roofnetclick $(1)/usr/bin/click 
        $(CP) $(PKG_BUILD_DIR)/tools/click-align/click-align $(1)/usr/bin/click-align
 endef
 
 define Package/roofnet/install
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/conf/wifi/gen_config_roofnet.sh $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/conf/wifi/srcr.click $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/conf/wifi/read_handler $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/conf/wifi/write_handler $(1)/usr/bin
-       mkdir -p $(1)/etc/init.d
-       install -m 755 ./files/roofnet.init $(1)/etc/init.d/roofnet
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/roofnet.init $(1)/etc/init.d/roofnet
 endef
 
 $(eval $(call BuildPackage,click))