mark click as broken for now - fails to build and should be replaced with a newer...
[openwrt/svn-archive/archive.git] / net / click / Makefile
index cfa49e835431153674ae89a5a7cce049d4b4c04e..f283f763c7081d93ebef4c79e5dd57505a29ece1 100644 (file)
@@ -26,6 +26,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/click
   SECTION:=net
   CATEGORY:=Network
+  DEPENDS:=@BROKEN
   MENU:=1
   TITLE:=The Click Modular Router
   DESCRIPTION:=The Click Modular Router
@@ -35,28 +36,30 @@ endef
 define Package/roofnet
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=click
+  DEPENDS:=@BROKEN click
   TITLE:=roofnet mesh networking scripts
   DESCRIPTION:=roofnet mesh networking scripts
   URL:=http://pdos.csail.mit.edu/roofnet/
 endef
 
-CONF_OPTS= \
-               ac_cv_int64_t=no \
-               ac_cv_sizeof_off_t=4
+BUILDOPTS = \
+               BUILD_CXX="g++ -I $(PKG_BUILD_DIR)/include-host" \
+               BUILD_DL_LIBS="-ldl"
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
-               $(CONF_OPTS) \
+               rm -rf config.{cache,status} ; \
+               CONFIG_SITE= \
                ./configure; \
-               cp include/click/config.h include/click/config-host.h; \
+               rm -rf include-host; \
+               $(CP) include include-host; \
                rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CXXFLAGS="-static -O2 -MD" \
                CFLAGS="-static -MD" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               $(CONF_OPTS) \
+               $(BUILDOPTS) \
                ./configure \
                  --prefix=/usr \
                  --target=$(GNU_TARGET_NAME) \
@@ -75,7 +78,7 @@ define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
        $(CONF_OPTS) \
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               BUILD_CXX="g++ -include $(PKG_BUILD_DIR)/include/click/config-host.h" \
+               $(BUILDOPTS) \
                tools elementmap.xml
        (cd $(PKG_BUILD_DIR)/userlevel; \
                ../tools/click-mkmindriver/click-mkmindriver -p roofnet -C .. \
@@ -86,19 +89,19 @@ define Build/Compile
 endef
 
 define Package/click/install
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/userlevel/roofnetclick $(1)/usr/bin/click 
        $(CP) $(PKG_BUILD_DIR)/tools/click-align/click-align $(1)/usr/bin/click-align
 endef
 
 define Package/roofnet/install
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/conf/wifi/gen_config_roofnet.sh $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/conf/wifi/srcr.click $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/conf/wifi/read_handler $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/conf/wifi/write_handler $(1)/usr/bin
        mkdir -p $(1)/etc/init.d
-       install -m 755 ./files/roofnet.init $(1)/etc/init.d/roofnet
+       $(INSTALL_BIN) ./files/roofnet.init $(1)/etc/init.d/roofnet
 endef
 
 $(eval $(call BuildPackage,click))