[net] Proxy Servers: Moved web proxy servers and related programs to Proxy Servers...
[openwrt/svn-archive/archive.git] / net / crowdcontrol / Makefile
index ce048b8539b9b479414295d64822761807dc792c..700ed1b258b877fcb42817f94162cf17af9229fa 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -13,17 +12,15 @@ PKG_VERSION:=0.4b
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@openwrt
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
 PKG_MD5SUM:=a0991ae3d1f1a361558bed1a4aa66a9c
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/crowdcontrol
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Proxy Servers
   TITLE:=The extra-light http proxy server
   URL:=http://sourceforge.net/projects/crowdcontrol/
 endef
@@ -42,8 +39,8 @@ define Build/Compile
 endef
 
 define Package/crowdcontrol/install
-       mkdir -p $(1)/usr/sbin
-       mkdir -p $(1)/etc/crowdcontrol
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/etc/crowdcontrol
        $(CP) $(PKG_BUILD_DIR)/crowdcontrol $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/*-{domains,expressions,urls} $(1)/etc/crowdcontrol/
 endef