Update nodogsplash to 0.9 beta9.9 (#3638)
[openwrt/svn-archive/archive.git] / net / crowdcontrol / Makefile
index 740648dc35670c5efcbd1ba5fc983c42eb195080..ddc49dfbf608bd632bbd8de6a18308f382060440 100644 (file)
@@ -11,11 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=crowdcontrol
 PKG_VERSION:=0.4b
 PKG_RELEASE:=1
-PKG_MD5SUM:=a0991ae3d1f1a361558bed1a4aa66a9c
 
-PKG_SOURCE_URL:=@openwrt/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_MD5SUM:=a0991ae3d1f1a361558bed1a4aa66a9c
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -26,12 +25,18 @@ define Package/crowdcontrol
   SECTION:=net
   CATEGORY:=Network
   TITLE:=The extra-light http proxy server
-  DESCRIPTION:=Crowd Control is an small, cross-platform HTTP proxy (a fork of the elhttp project)\\\
-       designed for systems with little RAM, such as a home router. It can filter URLs using\\\
-       SquidGuard blocklists, and has the unique ability to filter HTTPS domains as well.
   URL:=http://sourceforge.net/projects/crowdcontrol/
 endef
 
+define Package/crowdcontrol/description
+       Crowd Control is an small, cross-platform HTTP proxy (a fork of the elhttp project) 
+       designed for systems with little RAM, such as a home router. It can filter URLs using 
+       SquidGuard blocklists, and has the unique ability to filter HTTPS domains as well.
+endef
+
+define Build/Configure
+endef
+
 define Build/Compile
        $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/crowdcontrol $(PKG_BUILD_DIR)/crowdcontrol.c
 endef