[packages] ctorrent: fix build failure on avr32
[openwrt/svn-archive/archive.git] / net / ctorrent / Makefile
index 5f1028fb47d206f5901c15a47a0690ac1a812ddd..a5195a642ecd688cce33fc3c78d0eb054797fc33 100644 (file)
@@ -1,57 +1,84 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ctorrent
-PKG_VERSION:=1.3.4-dnh2
-PKG_RELEASE:=1
+PKG_VERSION:=dnh3.3.2
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.rahul.net/dholmes/ctorrent/
-PKG_MD5SUM:=6635e2d0d0ee21faeb85d95cd93c137b
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=@SF/dtorrent \
+       http://www.rahul.net/dholmes/ctorrent/
+PKG_MD5SUM:=59b23dd05ff70791cd6449effa7fc3b6
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-dnh2
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/ctorrent
+define Package/ctorrent/Default
+  SUBMENU:=BitTorrent
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenssl +uclibcxx
+  DEPENDS:=+uclibcxx
   TITLE:=console-based BitTorrent client
-  DESCRIPTION:=\
-       CTorrent is a BitTorrent client written in the C programming language, known to \\\
-       be a very robust and mature programming language, which produces fast and \\\
-       optimized application.
   URL:=http://www.rahul.net/dholmes/ctorrent/
 endef
-   
-define Build/Configure
-       $(call Build/Configure/Default, \
-               , \
-               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/openssl" \
-               CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
-               LIBS="-nodefaultlibs -lcrypto -luClibc++ -lm -lc -lgcc" \
-       )
+
+define Package/ctorrent/Default/description
+       CTorrent is a BitTorrent client written in the C programming language,
+       known to be a very robust and mature programming language, which produces
+       fast and optimized application.
+endef
+
+define Package/ctorrent
+$(call Package/ctorrent/Default)
+  TITLE+= (with OpenSSL support)
+  DEPENDS+=+libopenssl
+  VARIANT:=ssl
+endef
+
+define Package/ctorrent/description
+$(call Package/ctorrent/Default/description)
+ This package is built with OpenSSL support.
+endef
+
+define Package/ctorrent-nossl
+$(call Package/ctorrent/Default)
+  TITLE+= (with builtin SHA-1)
+  VARIANT:=nossl
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+define Package/ctorrent-nossl/description
+$(call Package/ctorrent/Default/description)
+ This package is built with builtin (Steve Reid's public-domain) SHA-1 support
 endef
-       
-define Package/ctorrent/install        
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ctorrent $(1)/usr/bin/
+
+CONFIGURE_VARS += \
+       CXX="g++-uc" \
+       CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
+       LIBS="-nodefaultlibs -luClibc++ $(LIBGCC_S) -lc"
+
+ifeq ($(BUILD_VARIANT),ssl)
+       CONFIGURE_ARGS += \
+               --with-ssl="$(STAGING_DIR)/usr"
+endif
+
+ifeq ($(BUILD_VARIANT),nossl)
+       CONFIGURE_ARGS += \
+               --with-ssl=no
+endif
+
+define Package/ctorrent/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/$(PKG_NAME)
 endef
 
+Package/ctorrent-nossl/install = $(Package/ctorrent/install)
+
 $(eval $(call BuildPackage,ctorrent))
+$(eval $(call BuildPackage,ctorrent-nossl))