[packages] ctorrent: fix build failure on avr32
[openwrt/svn-archive/archive.git] / net / ctorrent / Makefile
index b4f07cf1a59be98a1a8ec4eb4180443238276915..a5195a642ecd688cce33fc3c78d0eb054797fc33 100644 (file)
@@ -1,22 +1,22 @@
 #
-# Copyright (C) 2007,2008 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ctorrent
-PKG_VERSION:=dnh3.2
-PKG_RELEASE:=1
+PKG_VERSION:=dnh3.3.2
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.rahul.net/dholmes/ctorrent/
-PKG_MD5SUM:=23b37cd7b558ad6a27974b311499bab6
+PKG_SOURCE_URL:=@SF/dtorrent \
+       http://www.rahul.net/dholmes/ctorrent/
+PKG_MD5SUM:=59b23dd05ff70791cd6449effa7fc3b6
 
-PKG_FIXUP = libtool
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -37,64 +37,48 @@ endef
 
 define Package/ctorrent
 $(call Package/ctorrent/Default)
-  TITLE+= (with builtin SHA-1 support)
+  TITLE+= (with OpenSSL support)
+  DEPENDS+=+libopenssl
+  VARIANT:=ssl
 endef
 
 define Package/ctorrent/description
 $(call Package/ctorrent/Default/description)
- This package is built with builtin (Steve Reid's public-domain) SHA-1 support
+ This package is built with OpenSSL support.
 endef
 
-define Package/ctorrent-openssl
+define Package/ctorrent-nossl
 $(call Package/ctorrent/Default)
-  DEPENDS+= +libopenssl
-  TITLE+= (with OpenSSL support)
+  TITLE+= (with builtin SHA-1)
+  VARIANT:=nossl
 endef
 
-define Package/ctorrent-openssl/description
+define Package/ctorrent-nossl/description
 $(call Package/ctorrent/Default/description)
- This package is built with OpenSSL support.
-endef
-
-define Build/Template
-
-$(STAMP_BUILT)-$(2): $(STAMP_PREPARED)
-       -$(MAKE) -C $(PKG_BUILD_DIR) clean
-       $(call Build/Configure/Default,$(3))
-       $(MAKE) -C $(PKG_BUILD_DIR)
-       ( cd $(PKG_BUILD_DIR); mv -f $(PKG_NAME) $(PKG_NAME)-$(2) )
-       touch $$@
-
-$(STAMP_BUILT): $(STAMP_BUILT)-$(2)
-
-define Package/$(1)/install
-       $(INSTALL_DIR) $$(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME)-$(2) $$(1)/usr/bin/$(PKG_NAME)
-endef
-
+ This package is built with builtin (Steve Reid's public-domain) SHA-1 support
 endef
 
 CONFIGURE_VARS += \
        CXX="g++-uc" \
        CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
+       LIBS="-nodefaultlibs -luClibc++ $(LIBGCC_S) -lc"
 
-ifneq ($(SDK)$(CONFIG_PACKAGE_ctorrent),)
-  define Build/with-ssl
-    $(call Build/Template,ctorrent,with-ssl, \
-       --with-ssl=no \
-    )
-  endef
+ifeq ($(BUILD_VARIANT),ssl)
+       CONFIGURE_ARGS += \
+               --with-ssl="$(STAGING_DIR)/usr"
 endif
-$(eval $(Build/with-ssl))
-
-ifneq ($(SDK)$(CONFIG_PACKAGE_ctorrent-openssl),)
-  define Build/with-openssl
-    $(call Build/Template,ctorrent-openssl,with-openssl, \
-       --with-ssl="$(STAGING_DIR)/usr" \
-    )  
-  endef
+
+ifeq ($(BUILD_VARIANT),nossl)
+       CONFIGURE_ARGS += \
+               --with-ssl=no
 endif
-$(eval $(Build/with-openssl))
+
+define Package/ctorrent/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/$(PKG_NAME)
+endef
+
+Package/ctorrent-nossl/install = $(Package/ctorrent/install)
 
 $(eval $(call BuildPackage,ctorrent))
-$(eval $(call BuildPackage,ctorrent-openssl))
+$(eval $(call BuildPackage,ctorrent-nossl))