Update ctorrent to 3.3.2 (#3556)
[openwrt/svn-archive/archive.git] / net / ctorrent / Makefile
index 527c4a4cf0201d2f280e6638c999b8f0331c2689..ddc5f334524425a762905ac670e2e4535354ba6b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,49 +9,93 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ctorrent
-PKG_VERSION:=1.3.4-dnh3
+PKG_VERSION:=dnh3.3.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.rahul.net/dholmes/ctorrent/
-PKG_MD5SUM:=ebed47837b071ca35b78bc26f2229c03
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=@SF/dtorrent \
+       http://www.rahul.net/dholmes/ctorrent/
+PKG_MD5SUM:=59b23dd05ff70791cd6449effa7fc3b6
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-dnh3
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/ctorrent
+define Package/ctorrent/Default
+  SUBMENU:=BitTorrent
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenssl +uclibcxx
+  DEPENDS:=+uclibcxx
   TITLE:=console-based BitTorrent client
-  DESCRIPTION:=\
-       CTorrent is a BitTorrent client written in the C programming language, known to \\\
-       be a very robust and mature programming language, which produces fast and \\\
-       optimized application.
   URL:=http://www.rahul.net/dholmes/ctorrent/
 endef
-   
-define Build/Configure
-       $(call Build/Configure/Default, \
-               , \
-               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/openssl" \
-               CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
-               LIBS="-nodefaultlibs -lcrypto -luClibc++ -lm -lc -lgcc" \
-       )
+
+define Package/ctorrent/Default/description
+       CTorrent is a BitTorrent client written in the C programming language,
+       known to be a very robust and mature programming language, which produces
+       fast and optimized application.
+endef
+
+define Package/ctorrent
+$(call Package/ctorrent/Default)
+  TITLE+= (with builtin SHA-1 support)
+endef
+
+define Package/ctorrent/description
+$(call Package/ctorrent/Default/description)
+ This package is built with builtin (Steve Reid's public-domain) SHA-1 support
+endef
+
+define Package/ctorrent-openssl
+$(call Package/ctorrent/Default)
+  DEPENDS+= +libopenssl
+  TITLE+= (with OpenSSL support)
+endef
+
+define Package/ctorrent-openssl/description
+$(call Package/ctorrent/Default/description)
+ This package is built with OpenSSL support.
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+define Build/Template
+
+$(STAMP_BUILT)-$(2): $(STAMP_PREPARED)
+       -$(MAKE) -C $(PKG_BUILD_DIR) clean
+       $(call Build/Configure/Default,$(3))
+       $(MAKE) -C $(PKG_BUILD_DIR)
+       ( cd $(PKG_BUILD_DIR); mv -f $(PKG_NAME) $(PKG_NAME)-$(2) )
+       touch $$@
+
+$(STAMP_BUILT): $(STAMP_BUILT)-$(2)
+
+define Package/$(1)/install
+       $(INSTALL_DIR) $$(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME)-$(2) $$(1)/usr/bin/$(PKG_NAME)
 endef
-       
-define Package/ctorrent/install        
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ctorrent $(1)/usr/bin/
+
 endef
 
+CONFIGURE_VARS += \
+       CXX="g++-uc" \
+       CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
+
+ifneq ($(SDK)$(CONFIG_PACKAGE_ctorrent),)
+  define Build/with-ssl
+    $(call Build/Template,ctorrent,with-ssl, \
+       --with-ssl=no \
+    )
+  endef
+endif
+$(eval $(Build/with-ssl))
+
+ifneq ($(SDK)$(CONFIG_PACKAGE_ctorrent-openssl),)
+  define Build/with-openssl
+    $(call Build/Template,ctorrent-openssl,with-openssl, \
+       --with-ssl="$(STAGING_DIR)/usr" \
+    )  
+  endef
+endif
+$(eval $(Build/with-openssl))
+
 $(eval $(call BuildPackage,ctorrent))
+$(eval $(call BuildPackage,ctorrent-openssl))