[packages] send: fix more OpenSSL 1.0.0 fallout
[openwrt/svn-archive/archive.git] / net / cups / Makefile
index 1a2b969a2c8284640b6a1ab4f7d71c2fa44d33f4..1ab7769899814692ba15eb05385a9bd01a808243 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cups
-PKG_VERSION:=1.4.2
+PKG_VERSION:=1.4.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.tar.bz2
@@ -16,9 +16,7 @@ PKG_SOURCE_URL:= \
        http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/cups/$(PKG_VERSION) \
        ftp://ftp.easysw.com/pub/cups/$(PKG_VERSION) \
        ftp://ftp3.easysw.com/pub/cups/$(PKG_VERSION)
-PKG_MD5SUM:=d95e2d588e3d36e563027a963b117b1b
-
-PKG_BUILD_DEPENDS:=zlib
+PKG_MD5SUM:=8776403ad60fea9e85eab9c04d88560d
 
 TARGET_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
 
@@ -46,14 +44,17 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               --with-cups-user=root \
-               --with-cups-group=root \
+               --with-cups-user="nobody" \
+               --with-cups-group="nogroup" \
                --without-perl \
                --without-python \
                --without-php \
                --enable-shared \
                --enable-image \
                --disable-dbus \
+               --disable-dnssd \
+               --disable-launchd \
+               --disable-ldap \
                --disable-pam \
                --disable-slp \
                --disable-gnutls \
@@ -61,7 +62,7 @@ define Build/Configure
                --disable-cdsassl \
                --disable-ssl \
                --disable-gssapi \
-               --disable-slp, \
+               --disable-tiff, \
                UNAME="Linux" \
                LIBS="$(TARGET_LDFLAGS) -lz -lpng -ljpeg" \
        )