Disable dbus support with cups (#4161)
[openwrt/svn-archive/archive.git] / net / cups / Makefile
index 0dd4065cd11600a2536ce285a11576aad648114c..21238d418bdf2b52818229178e196a7bdefbffd2 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,30 +9,33 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cups
-PKG_VERSION:=1.1.23
-PKG_RELEASE:=1
-PKG_MD5SUM:=4ce09b1dce09b6b9398af0daae9adf63
+PKG_VERSION:=1.3.7
+PKG_RELEASE:=2
 
-PKG_SOURCE_URL:=http://ftp.funet.fi/pub/mirrors/ftp.easysw.com/ftp.easysw.com/pub/cups/$(PKG_VERSION) \
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.tar.bz2
+PKG_SOURCE_URL:= \
        http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/cups/$(PKG_VERSION) \
+       ftp://ftp.easysw.com/pub/cups/$(PKG_VERSION) \
        ftp://ftp3.easysw.com/pub/cups/$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.tar.bz2
-PKG_CAT:=bzcat
+PKG_MD5SUM:=db4a45a17104f10f3ee599d88267c9e5
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DEPENDS:=zlib
 
-PKG_BUILDDEP:=zlib
+TARGET_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/cups
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+zlib
+  DEPENDS:=+zlib +libpthread +libpng +libjpeg
   TITLE:=Common UNIX Printing System
-  DESCRIPTION:=A printer spooling system for devices with USB or LP support
   URL:=http://www.cups.org/
+  SUBMENU:=printing
+endef
+
+define Package/cups/description
+       A printer spooling system for devices with USB or LP support.
 endef
 
 define Package/cups/conffiles
@@ -42,25 +46,32 @@ define Package/cups/conffiles
 endef
 
 define Build/Configure
-$(call Build/Configure/Default, --with-gnu-ld \
---with-cups-user=root \
---with-cups-group=root \
---without-perl \
---without-python \
---without-php \
---disable-slp \
---disable-gnutls \
---disable-openssl \
---disable-cdsassl \
---disable-ssl \
---disable-slp \
-)
+       $(call Build/Configure/Default, \
+               --with-cups-user=root \
+               --with-cups-group=root \
+               --without-perl \
+               --without-python \
+               --without-php \
+               --enable-shared \
+               --disable-dbus \
+               --disable-pam \
+               --disable-slp \
+               --disable-gnutls \
+               --disable-openssl \
+               --disable-cdsassl \
+               --disable-ssl \
+               --disable-gssapi \
+               --disable-slp, \
+               UNAME="Linux" \
+               LIBS="-L$(STAGING_DIR)/usr/lib -lz -lpng -ljpeg" \
+       )
 endef
 
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
                DSTROOT="$(PKG_INSTALL_DIR)" \
                STRIP="/bin/true" \
                all install
@@ -68,47 +79,38 @@ endef
 
 define Package/cups/install
        rm -rf $(1)/etc/cups
-       install -d -m0755 $(1)/etc/cups
+       $(INSTALL_DIR) $(1)/etc/cups
        $(CP) $(PKG_INSTALL_DIR)/etc/cups/* $(1)/etc/cups/
        rm -rf $(1)/etc/cups/certs
        ln -sf /tmp $(1)/etc/cups/certs
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        rm -f $(1)/usr/bin/cups-config
-       install -d -m0755 $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.so.* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.so* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/cups $(1)/usr/lib/
-       install -d -m0755 $(1)/usr/share/cups/templates
+       $(INSTALL_DIR) $(1)/usr/share/cups/templates
        $(CP) $(PKG_INSTALL_DIR)/usr/share/cups/templates/*.tmpl $(1)/usr/share/cups/templates/
-       install -d -m0755 $(1)/usr/share/doc/cups
+       $(INSTALL_DIR) $(1)/usr/share/doc/cups
        $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/cups/index.html $(1)/usr/share/doc/cups/
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/cups/*.css $(1)/usr/share/doc/cups/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/cups/images $(1)/usr/share/doc/cups/
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
        # overwrite default config with our own
        $(CP) ./files/etc/cups/* $(1)/etc/cups/
        # install initscript with priority 60
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/cupsd.init $(1)/etc/init.d/S60cupsd
-       find $(1) -name CVS | xargs rm -rf
-       $(RSTRIP) $(1)
-       $(IPKG_BUILD) $(1) $(PACKAGE_DIR)
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/cupsd.init $(1)/etc/init.d/cupsd
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/cups-config $(STAGING_DIR)/usr/bin/
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/cups $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.{a,so*} $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf \
-         $(STAGING_DIR)/usr/bin/cups-config \
-         $(STAGING_DIR)/usr/include/cups \
-         $(STAGING_DIR)/usr/lib/libcups.{a,so*}
+       $(INSTALL_DIR) $(2)/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/cups-config $(2)/bin/
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/cups $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.so* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,cups))