fix cups build on osx
[openwrt/svn-archive/archive.git] / net / cups / Makefile
index e0ec160eafbbfa1952eacc3cd79ed172ca69e9eb..48cf229635f7b9ca715ad5311fe622ef784f4e8b 100644 (file)
@@ -23,7 +23,7 @@ PKG_CAT:=bzcat
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-PKG_BUILDDEP:=zlib
+PKG_BUILD_DEPENDS:=zlib
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -46,13 +46,13 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               --libexecdir=/usr/lib \
                --with-cups-user=root \
                --with-cups-group=root \
                --without-perl \
                --without-python \
                --without-php \
                --enable-shared \
+               --disable-pam \
                --disable-slp \
                --disable-gnutls \
                --disable-openssl \
@@ -67,6 +67,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
                DSTROOT="$(PKG_INSTALL_DIR)" \
                STRIP="/bin/true" \
                all install
@@ -74,28 +75,28 @@ endef
 
 define Package/cups/install
        rm -rf $(1)/etc/cups
-       install -d -m0755 $(1)/etc/cups
+       $(INSTALL_DIR) $(1)/etc/cups
        $(CP) $(PKG_INSTALL_DIR)/etc/cups/* $(1)/etc/cups/
        rm -rf $(1)/etc/cups/certs
        ln -sf /tmp $(1)/etc/cups/certs
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        rm -f $(1)/usr/bin/cups-config
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcups.so.* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/cups $(1)/usr/lib/
-       install -d -m0755 $(1)/usr/share/cups/templates
+       $(INSTALL_DIR) $(1)/usr/share/cups/templates
        $(CP) $(PKG_INSTALL_DIR)/usr/share/cups/templates/*.tmpl $(1)/usr/share/cups/templates/
-       install -d -m0755 $(1)/usr/share/doc/cups
+       $(INSTALL_DIR) $(1)/usr/share/doc/cups
        $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/cups/index.html $(1)/usr/share/doc/cups/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/cups/images $(1)/usr/share/doc/cups/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
        # overwrite default config with our own
        $(CP) ./files/etc/cups/* $(1)/etc/cups/
        # install initscript with priority 60
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/cupsd.init $(1)/etc/init.d/cupsd
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/cupsd.init $(1)/etc/init.d/cupsd
 endef
 
 define Build/InstallDev